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HOW TO VIEW FABRIC IN ARAHWEAVE

Your ArahWeave will open with a default fabric.
The first thread of the fabric is in the bottom left
corner.

Changing the default fabric

To change the default fabric, load the fabric and
select Help in the upper right corner. Choose Set
current fabric as default.

Program name and version
File name

Fabric repeat size in threads

Zoom

View quality

Red = unsaved changes
Green = all changes are saved

Mouse cursor.
Click and drag to pan Warp and weft position

of the mouse cursor

Fabric simulation

Ruler in cm, click to change to threads

Fabric repeat size

Combines the following repeats:
• weave
• thread pattern
• denting / regulator

If these three repeats are divisible, than the fabric
repeat is the same as the larger repeat. If they are
not divisible, than the fabric repeat is the smallest
number which divides all three repeats.

Making your first fabric with ArahWeave

To make a fabric, we need to define five things:
• weave (the interlace of threads)
• yarn colors
• warp and weft pattern (sequence of yarns)
• fabric density
• yarn properties

Zoom

Zooming in and out can be done in different ways:
• choose the zoom from the menu
• press + or - button on the keyboard
• hold Ctrl and roll the mouse wheel
• press shortcut keys 0 - 9 or Ctrl + 0 - 9

Zoom 1 shows the fabric in real size.

View modes

Weave = shows
the weave in
repeat

Integer = shows
yarn colors, ignores
fabric density

Simulation = realistic
fabric simulation, the
numbers refer to
simulation quality

Shaded integer
= integer view
with added
shades

Selecting, copying and exchanging properties

Left click = select

Right click = copy

Middle click (mouse wheel) = exchange
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Denting

End of denting repeat

Tie-up

Drafting (or Threading)

1 . To open the Weave editor, go to Weave > Edit,
or right click on the fabric simulation.

2. To display a dobby card and drafting
(threading), choose View > Dobby.

3. Middle-click inside the gray area, next to the
warp / weft pattern to change the size of the
weave. Or go to Edit > Dimensions.

4. To make a weave, do one of the following:
• Draw black points with left click, and white
points with right click. Use the tools from the
toolbox to speed up the drawing.

• Go to File > Browse and load a weave from
Arahne database.

5. Use the tools from the toolbox to speed up
your work. Tools also work on the selected part
of the weave. To make a selection, hold Shift
while draging the mouse.

6. To change the denting or regulator, do one of
the following:
• Write inside the Denting and Regulator field,
next to the toolbox.

• Draw inside the Regulator column, next to
the dobby card. Left click makes a black point,
right click makes a white point. The regulator
is active on black point.

HOW TO DRAW A WEAVE HOW TO MAKE A DOUBLE WEAVE

1 . Open the Edit weave window by going to
Weave > Edit.

2. In the new window, go to Edit > Dimensions
and set weave size and system. System is the
number of layers in warp and in weft.

Number of
layers in weft

Weave size

Number of
layers in warp

3. In the Edit weave window, go to Tools > Edit
decomposed . Enter the system, number of
layers in warp and weft in the upper right
corner.

4. Leave both Edit weave and Edit decomposed
windows open, so you can see the compound
weave and the decomposed weaves at the
same time. All changes made in Edit
decomposed window will be instantly visible in
Edit weave window and vice versa.

5. In Edit weave window, go to View > Cross
section to enable it.

Dobby card

End of warp pattern repeat

End of weft pattern repeat

Warp pattern

Weave

Size of weave; Number of shafts

Position of the
mouse cursor

Toolbox

Regulator

Weft pattern

Note: I f you would l ike to copy and paste a part of
weave, first select the part you would l ike to copy
(hold Shift while dragging the mouse). Then paste
it by cl icking dragging the mouse. Clear selection
when finished, cl ick the icon in the toolbox.
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HOW TO CHANGE COLORS OF THE YARNS

1 . To open the Color editor, go to Fabric > Colors.

2. Go to Choose and select the palette you use, for
instance PANTONE® for fashion and home.

3. Select color from the PANTONE® palette with
left mouse click and copy it inside warp / weft
palette with right mouse click.

4. Choose a color for the background.

PANTONE® palete
Warp palete

Color of the background

System

6. To edit decomposed weaves, do one of the
following:
• Draw black points with left click, and white
points with right click. Use the tools from the
toolbox to speed up the drawing.

• Go to File > Browse and load a weave from
Arahne database.

Compound weave

Red lines ind icate which threads are shown in the cross section

Fabric cross section

Decomposed weaves

Selected weave

• Press keys from 0 to 9 to load a default
weave.

7. To copy weaves in the Edit decomposed
window, select a weave by left clicking on the
gray area around the weave. When weave is
selected, its grid becomes red. Then right click
to copy the weave.

Weft palete

Warning! Copying in Edit colors window will copy
the color but not the yarn properties.
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HOW TO CHANGE WARP OR WEFT PATTERN

1 . Open the Thread pattern editor, by selecting
Fabric > Thread pattern .

2. Choose the unit in which you would like to write
the pattern (mm or threads) from the drop
down list in the upper left corner.

3. Write the warp and weft pattern. For instance
5A1 0B means the warp pattern is 5 threads of
yarn A and 1 0 threads of yarn B.
• Use the round parentheses to multiply a part
of the pattern. For instance 3(1 A1 B) means
repeat pattern 1 A1 B three times:
1 A1 B1 A1 B1 A1 B

• Use square parentheses to repeat a certain
pattern for a number of threads. For instance
5[1 A1 B] means keep repeating pattern 1 A1 B
for the next five threads: 1 A1 B1 A1 B1 A

Choose between mm or threads

Tools for weft

Tools for warp

Weft pattern

Warp pattern

Size of one repeat in threads

Size of one repeat in mm

4. Use the tools to move, mirror or elongate the
pattern.

5. Copy the pattern from warp to weft or
vice versa with green arrows if needed.
You can also copy a specific thread between
warp and weft palette. Select = left click, copy =
right click, exchange = middle click.

Drawing thread pattern directly in the fabric
simulation

Another way of changing the warp and weft
pattern is by drawing over the fabric simulation.
This function will not work if repeat is smaller than
1 0 threads.

1 . The Thread pattern editor window has to be
open, to enable drawing. Enter the number of
threads in your repeat. For instance 500A (500
threads of yarn A). Click OK.

2. In the Thread pattern editor window, choose
the yarn letter with which you would like to
draw.

3. The mouse cursor in fabric simulation changes
into cone or shuttle colored in the
selected color. Do one of the following:
• Click and drag to draw.
• Hold Ctrl and click to fill.
• Hold Shift and click to insert.

Weft palette

Warp palette

Mouse cursor for
drawing warp pattern

Warning! Copying in Edit warp and weft pattern
window will copy colors and yarn properties.

Tips: The asterisk beside letter in thread palette
shows threads used in the fabric. Click on a yarn
letter to see where it is used in the pattern. Press
enter and current cursor position wil l bl ink in the
fabric.

Sort yarn letters

Note: Double click on the yarn letter in thread
palette will protect the threads with that letter.
Area with protected yarn will not be modified.
Protection also works in weave editor.



www.arahne.si 7ArahWeave Dobby Quick Start

HOW TO CHANGE FABRIC DENSITY

1 . To change the density, go to Fabric > Density
and control. If the fields are grayed out, disable
Density from technical data (upper left
corner). Do one of the following:
• Enter warp and weft density
• Enter the fabric repeat in cm and the program
will calculate the density. Fabric repeat
combines weave repeat and thread pattern
repeat.

Warp density

Horizontal
repeat size

Vertical
repeat size

Weft density

1 . Enter the technical details through Fabric >
Consumption . You will need to know the
details of your loom settings.

2. Enter the required information. All variables
regarding fabric width are without selvedges.

Entry fields for
fabric technical data

Calculated data

Note: When Density from technical data is disabled,
some fabric simulation effects will not be visible
(empty dents, variable density, regulator).

Manual entry of density Density from technical data

3. If a field becomes red, it means that one of the
variables is wrong. Correct it manually or press
the light bulb to calculate it automatically.

4. Enable Density from technical data .

Enable density
from technical data

Disable Density from
technical data
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HOW TO CHANGE YARN DIAMETER

1 . To open the Yarn editor, go to Fabric > Yarns.

2. The asterisk beside letter in the palette
indicates which yarns are used in the fabric.
Click on the yarn you would like to edit.

3. Choose the unit for the yarn count, enter the
yarn count and number of plies.

4. Zoom in the yarn simulation and increase or
decrease the dimension factor to get the
desired yarn diameter.

Weft palette

Yarn simulation

HOW TO SAVE THE FABRIC

1 . To save the fabric, go to File > Save fabric as.

2. Navigate to the folder in which you would like
to save the fabric.
• Navigate by writing the path in the upper left
corner.

• By double clicking on two dots (..) in the
Directories section, which will move you one
directory up.

• By double clicking on the directory name.

3. Write the fabric name or click on the icon
to generate one from labels in properties.

Note: When saving the fabric, the following
parameters will be saved: weave, thread pattern,
used colors, used yarns, technical data, density,
regulator, denting. Saving fabric does not save
fabric as image.

Current d irectory is fabrics

Directories inside the current d irectory

Double click will move you one directory up

Files inside the
current d irectory

Path. Directories are separated with slash /

HOW TO SAVE FABRIC SIMULATION AS IMAGE

1 . Go to File > Print fabric to printer.

2. Choose the file type (JPG, PNG,TIFF,...) by
clicking on Printer setup. Select the desired
DPI . Click OK.

3. Enter the size of the printout in the upper right
corner.

4. Enable the options you would like to see on
your printout.

Yarn count unitWarp palette

Warning! Copying in Yarn editor window will copy
yarn properties but not the color.

Enter print size
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HOW TO SAVE WEAVE AND DOBBY CARD AS IMAGE

1 . Go to Weave > Edit, or right click on fabric
simulation, to open the Edit Weave window.

2. In Edit weave window, go to File > Print
weave. Choose the file type (JPG, PNG,TIFF,...)
by clicking on Printer setup. Select the desired
DPI . Click OK.

3. Enter the size of the printout in the upper right
corner.

4. Enable the options which you would like to see
on your printout. The dobby card is one of the
options.

HOW TO SAVE TECHN ICAL DATA SHEET

1 . Go to File > Save technical data as HTML.

2. Enable the options you would like to see in your
technical data sheet, and do one of the
following:
• Click OK to save the technical data sheet as a
HTML file. The information about file location
is written in the bottom left corner.

• Click Print to open the technical data sheet in
a web browser and save it at the same time.

Saved fi le location

Size of weave

If you would like to make a PDF file, open the
technical data sheet in a web browser (in previous
step click Print button).

In the web browser, go to File > Print. Depending
on the browser, choose PDF or Print to file > PDF.
Give it a name and click Print or Save.

Technical data sheet



© Arahne d.o.o. 1 992 - 2022

Novinarska 3, 1 000 Ljubljana, Slovenia

Phone: +386 1 439 5280

e-mail: arahne@arahne.si

www.arahne.si




