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1 INTRODUCTION

ArahPaint is a drawing tool that assists textile designers in editing images in repeat. These images are 

most commonly associated with jacquard-woven fabrics. ArahPaint is the first step in creating a 

weaving design. Both drawing operations and sophisticated woven-fabric-design functions are 

supported by the program. Drawing operations have unlimited undo, allowing you to quickly correct 

unwanted image changes. 

The reader should be familiar with graphical user interfaces because the fundamentals (mouse 

selection, double-click, buttons, file selection boxes, text entry and editing, and so on) will not be 

covered here. ArahPaint is intended for designers who are familiar with the weaving process. 

Specifically, the manual lacks detailed instructions for turning a design into a fabric (this is an area of 

ArahWeave). Many tools and functions in ArahPaint are useful for creating fabric patterns, but they 

cannot replace the skills, knowledge, and experience of a professional fabric designer. 

We hope you find ArahPaint to be a useful design tool in your everyday work. Please send any 

comments or suggestions to our email address, and we will do our best to improve the program. 

2 PROGRAM’S APPEARANCE

The main window appears on the screen after you launch the program by clicking on the ArahPaint 

icon (Figure 1). All menus are inactive except for the File, Edit, and Help menus until you create a new 

image, load an old one, or paste an image from the clipboard. 

Figure 1: ArahPaint on KDE Desktop 
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Figure 2 explains the components of Arahpaint’s main window:

Figure 2: Main window of ArahPaint

1. The title bar displays the program name, version and current design filename, size in pixels and

zoom level.

2. Menu bar.

3. Ruler (optional).

4. The main window is the area which displays the currently edited picture. Note that the first 

row of design is at the bottom of the picture, as this is usual in weaving.

5. The toolbox contains tools for creating and editing images.

6. Line width—this setting sets the width of lines, rectangles/squares, ellipses/circles, arcs, 

polygons, brushes. If you break the chain’s link by clicking on the chain icon , you can set the 

width in the x and y direction independently.

7. The drawing mode. The default is a standard drawing, indicated by a pencil.

8. If you set the width of a line to be more than 1 pixel, then you can choose the shape of the 

pen, which influences the look of the starting and ending points of the line and the shape of a 

single-click drawn object.

9. Color indicator shows which color is the foreground and which is the background. By double- 

clicking the color indicator, the color dialog box will pop up.

10. Pointer coordinates

11. Color RGB values of the pixel under the cursor.

12. Options of the currently selected tool.

13. Active layer number.

14. Panels (colors, layers, brushes).

15. Color palette (sometimes referred as color table or colormap).

16. Palette’s toolbar.
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 2.1 SETTING THE LANGUAGE

To change the user interface language of ArahPaint, choose Help

> Language and select the language from the list. You must

restart ArahPaint for the change to take effect.

 2.2 MEASUREMENT SYSTEM (METRIC OR IMPERIAL)
If you disable the Metric units option in the View 

menu, the measurement system is switched to 

imperial, or vice versa.

Figure 4: Changing the unit of measurement.

 2.3 SAVING OTHER USER-DEFINED SETTINGS

Normally ArahPaint runs alongside ArahWeave, which enables you to

modify and save ArahPaint’s preferences too. But if you want to use 

ArahPaint to save its current settings, you can do so by clicking the Save

setup menu entry (Help > Save setup). The current state of user interface

variables—they are listed and described in more detail in the subsections

below—is saved in the configuration file. Next time when you open 

ArahPaint these settings will be used.

 2.3.1 CHANGING THE DEFAULT LOAD AND SAVE LOCATION

If you want to change a default save location, navigate in the image browser to the desired folder, and 

click the Help > Save setup menu.

Figure 3: Setting the language

Figure 5: Saving the setup
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 2.3.2 THE IMAGE BROWSER PREFERENCES

The current sate of the image browser’s variables is saved when you click the Help > Save setup menu.

Figure 6: The view options in the image browser  

 2.3.3 SAVING THE DEFAULT WINDOW’S SIZE

If you want change the size of the ArahPaint’s window, scale it to desired size and click the Help > Save 

setup menu.

 2.3.4 OTHER SETTINGS

Beside a location, window sizes and image browser settings, the options under the view menu and 

Save as window are saved, when you click the Help > Save setup menu:

• Grid on/off

• Grid properties

• Integer view on/off

• Ruler on/off

• Measurement system (metric or imperial)

• Pen preview on/off

• Default image file format for saving

3 SUGGESTED SEQUENCE OF STEPS

The process of converting a design idea into a fabric can be divided into the following steps:

1. Preparation of the design with ArahPaint.

2. Preparing the necessary weaves in ArahWeave.

3. Combining the design and weaves into a jacquard control data with the color simulation on 

screen and paper.

4. Selecting the appropriate loom layout and saving the design in the desired jacquard format.

ArahPaint only covers the first stage – the preparation of the design – which can be subdivided into 

the following steps:

1. Drawing a design on paper.

2. Scanning the design into the computer.

3. Loading the design into ArahPaint program.

4. Cutting out the color border.

5. Scaling the image to the desired dimensions.

6. Setting the number of colors (weaves).

7. Cleaning the scanned picture.

8. Editing the picture.

9. Saving the final picture.
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 3.1 DRAWING A DESIGN ON PAPER

Drawing a design on paper is usually simpler and easier for a designer than drawing it directly into the 

computer. Therefore, a design can be drawn by hand on paper using traditional drawing techniques. 

The drawing can be black and white or colored. It is easier to color regions using Arahpaint’s bucket fill 

tool instead of doing it by hand.

The design does not need to be drawn in 1:1 scale because the computer can resize the image to any 

size. A design on paper does not need to exceed the size of A4 format. In this way, an A4 scanner will 

be enough to import the picture into ArahPaint.

 3.2 SCANNING THE DRAWING

Regardless of the scanner type, you should take care of that:

1. The image is aligned with the scanning area, which reduces the need to rotate the drawing later on.

2. The unnecessary white space should be cut out from the scanned picture. By using the preview 

mode, you can see the size of the drawing in correspondence to the scanning area. Use the 

bounding rectangle to limit the scanning area to the area actually covered by the drawing.

3. Choose a proper scanning accuracy. This is measured in dpi (dots per inch) and it ranges from 50 to 

2400 dpi. The bigger the dpi, the better the accuracy. But a better way to calculate the accuracy is 

to set the proper dimensions of a scanned drawing. The user usually knows in what quality the 

design will be woven. A particular design will be woven on jacquard looms with 1344 hooks. This 

means, the scanning width in pixels shall not exceed 150% of the hooks used. This means 

1344*1.50 = 2016 pixels of scanning width. Dividing the drawing width on paper in inches by 

scanning width in pixels will give us the dpi. Again, for our example, let's suppose the drawing is 15 

cm wide. Thus 2016/(15/2,54) = 341,3 dpi. By using this simple formula, the user can calculate the 

accuracy and/or scanning width, whichever can be set in the scanning software.

4. Set the proper saving format. For importing an image in ArahPaint, you can use PNG, GIF, JPEG, 

WebP, TIFF, PCX, BMP graphic file format. In total, 72 file formats are supported, including many 

weaving related ones (dobby and jacquard card machine formats). Vector formats like PDF, PS or 

SVG can also be imported. If you encounter an unsupported image format, you can use the program

Gimp to convert the image into one of the supported formats.

5. Save the drawing into the desired directory.

4 BASIC OPERATIONS

For effective use of the program, you should be familiar with some basic functions, like loading and 

saving files, selecting a region, setting colors... In this chapter we will not explain them in full detail, 

just enough to enable you to work with the program. You should understand the basic operations 

before continuing with the other chapters.
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 4.1 CREATING NEW IMAGES

The New picture... command from the File menu (Ctrl+N) lets you 

create a blank image. 

In the pop-up window you can set the following parameters:

• Size: Width (this will usually be equal to the number of pattern 

hooks on your jacquard head) and Height (this will usually be 

equal to the number of wefts/picks in your design).

• Color depth (for jacquard, you will mostly use indexed-color 

images (color palette images), which enable you to work with up 

to 256 colors.

• The fill type of the new image.

Figure 7: New picture dialog

 4.2 LOADING IMAGES INTO ARAHPAINT
To open a file, choose File > Load picture... (keyboard shortcut Ctrl+O). In the Load picture dialog box, 

select the name of the file you want to open. The appearance of the File selection dialog depends on 

the operating system you are using.

The program can load pictures in PNG, GIF, PCX, BMP, TIFF, WebP and JPEG graphics file formats. Also, 

it supports most of the jacquard specific machine formats (TIS, Grosse, Stäubli, Bonas, Schleicher) and 

some competitors (Sophis, EAT) as well. Additionally, ArahPaint imports some vector formats – SVG, 

PDF and SVGZ.

If you enable the Hide load menu, use browse option ArahWeave, then the Load file command opens 

the Browse images dialog, and not the Load picture dialog.

Figure 8: File selection dialog on Linux
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Figure 9: File selection dialog on Windows 7
 

Figure 10: File selection dialog on Mac OS X  

 4.3 LOADING FILES FROM IMAGE BROWSER

To load a file using the Image Browser, choose File > Browse... (keyboard shortcut: Ctrl+Shift+O). The 

image browser displays thumbnails of image files to identify each image.

The text labels below the image icons have different background colors. Currently selected image has a

text label in yellow, so you can quickly find it. Bi-level (black and white) images have a light gray 

background of the filename area, indexed-color (8-bit) images have it in white, true-color images have 

a background in light pink, and images with alpha channel (transparency) have light-blue labels (Figure

11). So you can quickly distinguish jacquard cards or weaves (black and white), scanned images (true 

color) and cleaned up palette images.

Figure 11: Four different color tags help distinguish between file types.
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When hovering over the image icon, a tooltip appears, showing a filename, image size in pixels, 

number of colors, density (dpi) and physical size, file size and date of modification.

Figure 12: Image browser

Do one of the following to open the image in ArahPaint:

• Double-click an image file.

• Select an image file and then click OK, or press Enter.

The meaning of icons in the toolbar is described in the following table.

One directory up Rename image

Reload Delete image

Back to default directory Open image in a new ArahPaint window

Details view mode PNG and JPG optimizer (a keyboard shortcut is . 

(period))

The options icon menu and filter options are positioned at the bottom of the window.

• The Filter option allows you to search for particular images by size X, size Y, date of creation, file 

name, file format, and color depth. The program will interactively change the display to show you 

only pictures which match the search filter. In this way you will find the image you are looking for 

very quickly.
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Figure 13: The filter finds 9 images out of 290 that meet the set criteria.

• The sort drop-down option button allows you to choose a criterion, by

which you want to sort the fabric files. The default criterion is the name,

followed by file type, file size, date, image size in the horizontal direction, 

image size in the vertical direction, image size in both directions, number of

used colors, dpi and physical size.

• The Repeat option is enabled by default. It means that the 

image icon is displayed in continuous repeat; if disabled, the 

icon shows the image as it is.

Figure 15: Same image displayed in
repetition, with a repeat option

enabled (left), and disabled.

• Then there are some options to change what is shown in the information below fabric icons: 

Filename, Suffix, Size in pixels, File size, and Date.

• The vector preview enabled  will calculate the preview icon also on PDF, Postscript or SVG 

files. Since this is quite a time consuming operation (large multi-page PDF files must be read 

entirely), it is turned off by default. You can enable it if preview of vector files is important to you, 

and if the number of vector files in a directory is not too big.

Figure 14: Menu of
sorting criteria
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Figure 16: Preview of vector files in the image browser.

 

• To check the number of files and sub-directories in

the directories displayed in the Browse window, do

enable the Show number of files option . The

number of files in the directory is displayed below

the directory icon, the number of sub-directories is

displayed next to the directory icon.

Another useful function of the image browser: pressing the first letter of directory or file name 

positions selection on a directory or file whose name starts with that letter.

 4.3.1 IMAGE PREVIEW

To preview an image, position the pointer over a thumbnail and click with the right mouse button. The 

Preview window in a full screen mode will appear. The arrow keys (← ↑ → ↓) move the image in the 

window in the desired direction. Default view size is set to 100%, the repeat view is on. Press F on the 

keyboard to fit the image in the window. Use + and – or Ctrl+mouse wheel to zoom in or zoom out (or 

1,2,3,... for zoom 100%, 200%, 300%...). R toggles between the single image view and the repeating 

image view. The Page Down key loads the next image, the Page Up key loads the previous one. The 

Home key loads the first image in the directory, the End key loads the last one. 

To close the Preview window press the Esc key, or click with the right mouse button in the preview 

window.

Figure 17: The number of files in directory and
the number of sub-directories
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Figure 18: The image preview window

 

 4.3.2 THE DETAILS VIEW

The image browser also supports the details view, which displays each file in a separate line, as a file 

name followed by information about the image: Date, File type, Size x, Size y, Colors, dpi X, dpi Y, 

Width(cm), Height(cm), File size. You can sort images by any of these criteria. To change the sort key, 

click in the title of the list. A column of this property is highlighted in yellow. To switch from icon view 

to details view click the details view icon , to go back click the icon view icon .

Figure 19: The image browser in the details view mode.

 

 4.3.3 BROWSING SUBDIRECTORIES

ArahPaint’s browser is capable of showing files in subdirectories. It is very useful when you search for 

a file, but you don’t know where you have saved it. If there are directories in your parent directory, 

then the Image browser displays the “leafless tree” icon  at the top right corner of the window (in 

the same line as a directory path). To display all files from subdirectories, click the tree icon. It changes

to the “tree with leaves and fruits” icon , which means that the Image browser shows all files from 
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the parent directory and its subdirectories. If an image was found in a subdirectory, then the name of 

the subdirectory appears in the image icon.

 4.3.4 RENAMING FILES

You can also rename image files from the Browse window: left-click the name below the image’s icon, 

or  icon in the toolbar. A small window appears and you just type the new name and press Enter.

 4.3.5 DELETING FILES FROM ARAHPAINT

If you want to delete a file, or image file, choose File > Browse..., select a file you want to delete, and 

press Delete button on your keyboard, or click  icon in the toolbar. You will be warned before the 

file is actually deleted, but once you do it, there is no way back.

 4.3.6 OPTIMIZING PNG AND JPG FILES

ArahPaint’s image browser enables you to reduce the file size of older png and jpg images or images 

that you get from other sources. To use this function, select the image icon, and click the Optimize 

PNG and JPEG images icon  or select the keyboard shortcut Period (.). After it finishes—few seconds

for large files—the pop-up dialog shows the information about size reduction or tells that the file is  

already optimized.

Figure 20: Information about file-size reduction after using the
PNG optimizer.

 

 4.4 OPENING IMAGE FROM DESKTOP OR FILE MANAGER

You can open an image file from desktop or file manager by dropping the image icon over the 

ArahPaint shortcut icon.

Figure 21: Opening an image from Desktop (or File manager)
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After dropping an image icon into ArahPaint’s icon, the program starts with that image loaded.

Figure 22: After you have dropped a file icon over ArahPaint program shortcut, a file icon moves
back to its previous position and program opens with image loaded

 

If you drag-and-drop an image icon into an already running ArahPaint, it will load it as a layer onto the 

currently loaded background image.

 4.5 LOADING RECENTLY USED FILES

ArahPaint remembers recently used files and directories. To open one of recently used files, choose 

File > Load recent... The menu of the recently used files consists of two sections, one displays recently 

saved files, the other displays recently viewed files.

Figure 23: The load recent menu with file icons 

 

You can set the number of recently used files in the Number of recent files field in Save setup > 

Appearance in ArahWeave.

To open a list of the directories that you most recently accessed through the Load picture, Save as, or 

Browse dialog boxes, click the arrow at the right side of the Location bar. These directories are sorted 

by access time with the most recent at the top, least recent going down on the list.
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Figure 24: Most recently used directories list 

 

 4.6 SAVING A DESIGN

You can save the image under an existing name by selecting the command Save from the File menu 

(keyboard shortcut Ctrl+S).

In case you want to change the name of the design, invoke the command Save as from the File menu 

(keyboard shortcut Ctrl+Shift+S). This action will bring up the file selection box, where you can choose 

the desired directory and enter the new file name. If the file with the same name already exists, 

ArahPaint warns you before saving. The program gives you the option of either overwrite the existing 

file or change the file name.

The default file format for image saving is PNG. You can save an image in five other formats: TIFF, GIF, 

JPEG, WebP, and BMP. To specify the file format, you have to write the proper file extension to the file

name.

 4.7 IMPORTING VECTOR IMAGES (SVG, PDF) INTO ARAHPAINT

ArahPaint supports importing of Scalable Vector Graphics images (svg and svgz extension) and images 

(documents) in Portable Document Format (pdf extension).

To import a vector image into ArahPaint, choose File > Import vector image... (instead you can use File 

> Browse… and import a vector file from regular image browser). In the Load picture dialog, the correct

filter (Files of type) is already set to svg, pdf, and svgz file types, so the dialog displays only files in 

these three formats. Then choose a file which you want to import, and click Open. The program pops-

up the Import vector image dialog, showing the preview of the image next to the Width and Height 

field. Enter the width and height in pixels. If you break the chain by clicking on it ( ), you can change 

the Width and Height separately.
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Figure 25: Importing vector image into ArahPaint
 

After clicking the OK button, the image appears in the main ArahPaint window.

If you import a PDF file, the Import vector image dialog is slightly different, because a PDF file can 

consist of several pages. You can select more pages of the image (document) for importing, which are 

then opened as layers in ArahPaint. Also, you can set the density and size of the imported image.

Figure 26: Importing a PDF file into ArahPaint

 

 4.8 CLEAR IMAGE

You can get a new image from the previously loaded one. Use Edit > Clear, and all colors in the image 

change into the currently selected foreground color. The difference to the New image function is that 

you keep colors from the old image in the Color palette. If you use the New image function, you get 

sixteen random colors in the Color palette.

 4.9 UNDO / REDO

We want you to be able to freely experiment with the program, without fear of damaging the image. 

So you need to be able to undo the drawing operations.

The Undo command in the Edit menu (Ctrl+Z, ) restores the picture to its previous state. To Redo 

last operation, choose Edit > Redo (Ctrl+Y, ). The number of the undo steps is unlimited.
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 4.10 MAGNIFYING OR REDUCING THE VIEW

You can magnify or reduce your view using various methods. The main window’s title bar displays the 

current zoom level.

There are four ways to change the zoom level in ArahPaint:

1. Press the plus key (+) to zoom in, or press the minus key (-) to zoom out.

2. Press Ctrl on the keyboard and roll the mouse wheel up or down.

3. Click the icon  or  in the toolbox. 

4. If you press any number from 0-9 on the keyboard, you will change the zoom directly to that level 

(1 means 100%, 6 means 600%, 0 means 1000%).

The program will zoom in or zoom out at the current position of the cursor. You can also change the 

zoom level during drawing operations.

 4.10.1 FIT TO WINDOW

If you want that an image fits the entire available space in the main ArahPaint window, choose Fit to 

window from the View menu or select Ctrl+0 (zero).

 4.10.2 ALTERNATING BETWEEN CURRENT ZOOM AND 100% ZOOM

Pressing the Esc key on keyboard toggles back and forth between currently selected zoom level and 

100% zoom.

 4.10.3 GRID

At zoom levels higher than 300%, the program shows a grid 

between pixels if the grid view is enabled.

To show or hide the grid, choose View > Show Grid (Ctrl+G).

To change the grid properties, choose View > Grid properties... 

You can change the grid color to black, gray or white color. The 

second level grid determines after how many thin lines a thicker 

one will be drawn.

If you select the Unit(cm) checkbox, the program will match the 

Width and Height to the density, which is set in the Resize image 

window.

Figure 27: Set grid properties

 4.10.4 ANTI-ALIASING

When you zoom out the picture, the anti-aliasing (View > Antialias) smooths the jagged edges in the 

image by softening the color transition between edge pixels and background pixels.

Figure 28: Same design, viewing at zoom out 30%, with anti-alias off and on  
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 4.11 RULER

Ruler helps you position items (such as selections, layers, and

shapes) precisely across the width or length of an image.

When visible, ruler appears along the top and left side of the

main window. Markers on the ruler display the pointer’s

position when you move it. To show or hide ruler, choose 

View > Ruler or press Ctrl+R on the keyboard. It displays the

length and position in pixels or in centimeters. To switch

between the two units, click the ruler unit indication (points,

cm) (see Figure 29).

 4.12 DISPLAYING THE RGB COLOR VALUES

ArahPiant displays the color RGB values of the pixel under 

the mouse pointer, while you move it across the image. If 

you work on indexed color image, then the color position 

number (index) is displayed next to the color RGB value.

 4.13 GUIDES

In addition to the image grid, ArahPaint also gives you a 

more flexible type of positioning aid: guides. These are 

horizontal or vertical lines you can temporarily display on

an image while you are working on it.

To create a guide, simply double-click one of the rulers in 

the main window. The guide is then displayed as a blue, 

dashed line, which follows the pointer. 

You can create as many guides as you like, positioned 

wherever you like. To move a guide after you have 

created it, hover a mouse pointer over the blue arrow, 

which indicates the position of guide in the ruler. The 

mouse pointer changes to the move guide icon . You 

can then click and drag a guide to a new location. To 

delete a guide, double-click the blue arrow in the ruler. 

To remove all guides at a same time, choose View > 

Remove guides.
Figure 31: Double-click in the ruler creates a

guide

Figure 29: Ruler unit

Figure 30: Displaying the color's
position number and the RGB color
value of the pixel under the pointer
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 4.14 MEASURE TOOL

The measure tool lets you measure 

the distance between two pixels in 

the image. To use it, click  icon in 

the Toolbox (shortcut Shift + I), draw a

line between two points, and the 

program will display the length in 

points, cm and inches.

The measure tool has additional tools beneath it—Split, Merge, Move, Tilt, and several parameters for 

each of these tools. Value, x, and y are also used for some of the Filter tools (Chapter 13).

 4.15 CROSS-HAIR CURSOR

The cross-hair cursor helps you drawing or checking the picture more precisely. To switch it on, use 

View > Crosshair cursor, or more convenient, use the keyboard shortcut Z.

Figure 33: The cross-hair cursor (mouse pointer) at zoom 100%, and at zoom 500%

     

 4.16 PAN TOOL

To pan the image, move it while holding the middle button down. When you press the button, and 

during moving, the cursor pointer changes to four arrows shape (  ).

Figure 32: Measure tool displays distance in points, cm and
inches
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 4.17 USING THE TOOLS

Some tools in the toolbox let you select, edit, and view images; other tools 

let you paint, draw, and type.

Toolbox: You can view information about any tool in the toolbox by 

positioning the mouse pointer over it. The name of the tool appears below 

the pointer. You must click a tool’s icon in order to use it. The currently 

selected tool is highlighted (or colored) in the toolbox.

To select a tool, click its icon in the toolbox or press the tool’s keyboard 

shortcut. The keyboard shortcut is displayed in its tool tip. For example, you 

can select the Magic wand selection by pressing "w".

Foreground (upper square) and background color (lower square) are used in 

drawing operations.

Foreground color determines the color drawn with the left mouse button, 

and background color drawn with the right button. In this way, you can 

contemporary draw with two colors, without the need to constantly change 

drawing color. This is particularly handy, when you are fixing borders 

between two color areas. To change the foreground color, click a desired 

color in the color table panel.

Some drawing operations, like gradient tools, use both colors at same time, 

and you may get interesting effects, if you set one of them to be transparent.

You achieve this by right-clicking on a colored tile that represents the color of

the drawing or the background color. The clicked tile changes the color 

surface into the gray-checked pattern .

Option area: The first thing you should do after you select a tool is to set its 

options (if the tool has them). The options appear below the toolbox. The 

options area is context sensitive—it changes as you select different tools. 

Some settings in the options area are common to several tools, and some are

specific to one tool.

Panels: Colors, Layers, Brushes. To switch between panels, just click one of 

the Panel tabs (colors tab  F6, layers tab  F5, brushes tab  F7). 

Tools unique to each panel are at the bottom of the panel area.

Figure 34: Toolbox, tool
options, and color

palette

 4.18 SELECTING A RECTANGULAR AREA OF A DESIGN

We often want to limit the area of an operation to a specific part of the image. By selecting a particular

rectangular region, you set the boundaries of the operation.

The selection tool works in the following way:

1. Select the rectangular selection tool by pressing the icon in the toolbox .

2. Move the mouse pointer to one of the corners of the area you want to select.

3. Press left button and drag the mouse until the desired area will be inside the dashed rectangle.

By default, a selection border is dragged from its corner.

4. Release the button.

If you want to change the size of the selection, you can do it by:

1. Moving the pointer to the border of the dashed rectangle (from the inside out) until the 

pointer shape changes.

2. Pressing the left button and dragging the mouse until the desired rectangle size is achieved.
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The selected area becomes a layer, which 

can be moved, copied, pasted, or saved as

an image. The information about the size 

and position of the layer indicates the 

presence of the selection in the image. It 

is displayed in the option area in the 

toolbox. Figure 35 shows layer size of 360 

pixels by 400 pixels, while the layer’s left 

bottom corner is at pixel x=712, y=564. 

During the selection phase, the 

coordinates are grayed out, indicating 

that you can still change the size of the 

selected area. 

But after you move it, or select the 

Repeat selection checkbox (the line is 

changed to a dotted line  ), 

and you can’t change the size of selected 

area anymore.

Figure 35: The size and position of the layer are highlighted
in red. During this phase, you can still change the size of the
selected area (the coordinates of the starting point (x and y)

are grayed out). 

 4.19 CROPPING TO SELECTION

You can remove the area that lies outside 

of the current selection by using the Crop 

to selection command from the Image 

menu. 

Figure 36: Before and after cropping

 4.20 TRIMMING PICTURE OR LAYER

You can remove the area that is 

only made up of background color

pixels by using the Trim command

from the Image menu. The 

remaining area is a rectangle 

whose sides touch the edges of 

the non-background pixels.

When the function is applied to a 

layer, the result is a newly shrunk 

layer. 
Figure 37: The selection area is shrunk to a rectangular area that

covers all non-background color pixels after applying the Trim
command to the layer. 
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 4.21 DESELECTING A LAYER

If the selected area–selection is no longer needed, and you want to put it back into the background 

image do one of the following:

• Click  in the toolbox.

• On keyboard, press Ctrl+D.

• Right-click outside of selection somewhere on the background image (works, if one of selection 

tools is active).

The selection will be merged into the image at its current location.

 4.22 DELETING A LAYER

To delete a selection, press Backspace or Delete on the keyboard. To cut a selection to the Clipboard,  

choose Edit > Cut (keyboard shortcut Ctrl+X).

5 DRAWING OPERATIONS

Drawing operations are drawing tools like line, freehand, polygon, 

rectangle/square, ellipses/circles, arc drawing, fill area and eraser. All these 

tools are accessible through icon buttons in the toolbox. Tools use the 

foreground (drawing) color to draw with the left button, and background color 

with the right button. The icon below the line width field (the default is the solid

mode, indicated by the pencil icon ), lets you choose among different drawing

modes. For instance, if you have a brush selected, and the brush mode  is 

chosen from the pen mode selector you will paint with a brush (pattern). The 

other modes are the gradient type of tools, mixing foreground or background 

color in a specific way, indicated by the selected mode icon.

The options for the selected tool appear below the toolbox. The options area is 

context sensitive, which means that it changes as you select different tools. 

Some settings in the options are common to several tools, and some are specific

to a single tool.

Figure 38: Toolbox
and pen modes

 5.1 LINE WIDTH

The line width determines the width of drawing with the free-hand drawing tool, the line tool, and the 

width of the border of geometrical shapes. (The line width number is used as a parameter in several of

the filter operations; more on this in the following chapters.)
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Figure 39: Drawing with a line thickness of 6 pixels.
 

The breaking a chain link  next to the Line width field allows you to set the width of drawing in 

horizontal and vertical direction independently, usually according to the density (image dpi) settings.

Figure 40: Different widths can be set in the x and y drawing directions.  
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 5.2 DRAWING MODES

In addition to the default drawing mode (solid color), each drawing tool can

use additional modes from the icon menu, which is accessible by clicking on

the icon of the currently selected mode. The pencil icon  represents the 

default, which is drawing with a foreground color. After the brush , there 

are twelve gradient modes. The gradient mode’s icon indicates the 

direction of the gradient effect.

If there are no brushes in the brushes panel, the brush icon mode is not 

present in the pen modes menu.

Figure 41: Choosing the
pen mode.

 5.2.1 PEN MODE AND FILL(%)
If the Fill(%) option, located beneath the pencil icon , is set to 100% (which it usually is), the drawing

color will be a foreground color. If it is set to a number less than 100, the drawing color will be a 

proportional mix of foreground and background colors. The two preview color ribbons help to achieve 

the desired effect. The first ribbon contains a slider that allows us to change the percentage number, 

and the ribbon below shows a preview of the current setting.

This color mixture is then used for all drawing operations, including free hand drawing, drawing 

geometric shapes, and filling in areas with color.

Figure 42: The fill at 40%: the left image shows a full circle drawn with a dotted pattern, while the
right image shows a full circle drawn with a line pattern.  

 5.2.2 GRADIENT DRAWING MODES

You can choose among twelve drawing-gradient options. The direction of gradient effect is indicated 

by the mode icon. When one of the gradient modes is selected, all the drawing operation will draw 

that type of gradient instead of the solid color.
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 5.3 PEN SHAPES

If the line width is set to value higher than 1, you can choose among seven 

different pen shapes. As you click the icon next to the pen mode chooser, 

the drop-down list of pen-shape icons appears, and you can select one of 

them.

The shape of the pen influences the shape of the line/free-hand/arc/curve 

drawing's beginning and ending points, the shape of angles of drawn 

rectangles and squares, and the shape of spray dots.

Figure 43: A drop-down
list of pen shapes

The table below displays results of drawing at line width of 16 pixels with different pen shapes.

Line

Rectangle

Circle

 5.4 DRAWING STRAIGHT LINES

Use the straight-line icon button  (keyboard shortcut I) to activate this tool. Then move the mouse 

pointer to a line starting point in the picture and press the left button. Drag the mouse until the line is 

of the desired length and angle. Then release the button.

Tool options are:

Thick lines: use this option when you want to have 

diagonal pixels connected (it works only at line width 1). 

The line on the left is “normal”, the one on right is thick.

Figure 44: Normal line and thick line
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Keep aspect: if your image density (dpi) ratio is 

different from 1, the physical size of horizontal 

and vertical lines, drawn with the same pixel 

width, is different. By using the keep aspect 

option the pixel width of one of the lines (that 

one which would be thicker) is reduced to be 

similar as the thinner one. In Figure 45, lines 

and circles, which are drawn in normal mode 

(line width is set to four pixels) in blue, lines 

drawn while the Keep aspect option is on, are 

in red color.

Figure 45: Lines in red are drawn using the Keep
aspect mode

 5.4.1 PARAMETRIC DRAWING

Straight lines can be drawn by supplying the parameters – starting point coordinates, length in pixels, 

and either ending point coordinates or drawing angle. ArahPaint generates a line based on this data 

when you confirm the settings by clicking the Confirm button .

Figure 46: Setting parameters to draw a line.

Using parametric drawing, you can create designs that would be difficult to draw otherwise, such as a 

group of lines with the same starting point and a fixed angle between them.

Figure 47: Lines with a 12° angle between them.
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 5.5 DRAWING PERFECTLY HORIZONTAL, VERTICAL OR DIAGONAL LINES

Drawing straight lines has a powerful extension: if you double-

click the Straight line icon, it changes to . Now you can draw 

horizontal, vertical or diagonal lines. If you move a mouse 

horizontally—it doesn’t need to be perfectly straight, the drawn 

line is horizontal. If the angle between a line and the horizontal 

axis exceeds the angle of 23 degrees, the drawn line will be 

diagonal at 45 degrees. If you move the mouse toward the 

vertical axis, the line will be drawn as a vertical line.

 5.6 FREEHAND DRAWING

Click the freehand draw icon  to activate one of the most frequently used tools (keyboard shortcut 

P). Simply move the mouse pointer to a starting point in the image, click and hold the left mouse 

button, and drag the mouse as if you had a pencil in your hand. Release the mouse button to stop.

In addition to drawing straight lines, it has an additional option, the Stamp tool (see Chapter 10.2.2).

 5.7 POLYGON DRAWING

The polygon is a series of straight lines, whose ends are connected, so that the ending point of one line

is the starting point of the next line. It is useful for drawing figures which will be colored later with the 

fill area tool. Since lines are connected, coloring the figure will not leak out of the figure’s boundaries.

Polygon drawing is different from line drawing:

1. Select the polygon icon .

2. Move the mouse pointer to the starting point and left-click.

3. Move (not drag) the mouse to the next point and left-click again.

4. Repeat step 3 until the desired polygon is drawn.

5. Press the right button to stop polygon drawing or middle mouse button to erase the last 

polygon point. 

 5.8 DRAWING RECTANGLES/SQUARES AND ELLIPSES/CIRCLES

Drawing ellipses/circles is very similar to drawing rectangles/squares.

First click the desired icon button -  or  or  or .

1. Move the mouse pointer to the one corner and press the left mouse button.

2. Drag the mouse to the opposite corner of the (bounding) rectangle.

3. Release the mouse button.

In the case when physical width and height of the repeat are not equal and you are drawing 

circles/squares, the program calculates the size of the circles/squares to match the ratio of width to 

height.

When drawing in zoom, if the ratio of the resizing factor of width to height matches the ratio of the 

picture’s real size width to height (in mm), then the objects will be visible in the right proportions as 

well. 

If the icon button of the selected operation is filled (not empty), the object will be filled as well. You 

can toggle the fill attribute by double-clicking on the same icon button (for instance square). The icon 

Figure 48: Drawing straight lines
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will be changed from  into  and the next drawn object will be filled. This works also for the 

Polygon drawing.

 5.9 DRAW A LINE ACROSS THE IMAGE

The drawing lines across the image is the 

extension of the rectangle tool. The 

rectangle tool should be in the “fill” mode

 (double-click  to change the 

mode). Choose whether you want to draw 

horizontal or vertical lines in the choices 

box. Simply click in the image, hold down 

the button, and drag the mouse until the 

line is the appropriate width to create a 

line.
Figure 49: Drawing lines across the image

 5.10 DRAWING ARCS

An arc is a part of an ellipse or a circle. It is used for drawing round shapes like flower leafs and similar 

round objects. Three points determine an arc: first and second mark the starting and ending point of 

the arc, while the third one sets the curvature.

1. Select the arc icon button  or use the keyboard shortcut D.

2. Move the mouse pointer to the point where the arc will start, and press the left button. The 

program will draw a cross on that point.

3. Move the mouse pointer to the point, where the arc will end, and press the left button. The 

program will draw a cross on that point.

4. Now move the mouse pointer to the point of maximum extent of the arc’s curve, and press 

and hold the left button.

5. Drag a mouse until the desired arc is drawn, and release the mouse button.

 5.11 DRAWING CURVE

The curve tool lets you draw or trace curved shapes. The last three clicked points determine the curve 

between those three points. Follow these steps to draw the curve:

1. Select the icon .

2. Move the mouse pointer to the starting point, and press the left button.

3. Move (not drag) the mouse to the next point and press the left button again.

4. Repeat step 3 until the desired curve is drawn.

5. Press the right mouse button to stop curve drawing.

 5.12 BÉZIER TOOL

It allows you to create a complex object quickly and simply. A combination of linked bézier curves is 

commonly called a path. The path consists of two components: straight and curved segments.

To draw the bézier curves, select the Bézier tool  from the toolbox, then click in the image to 

create the first point. To draw a straight line, click where you want to end it. Move the mouse to a new

point and left click the mouse to create another point linked to the previous point. The blue circles are 

anchor points, two green squares are control points (sometimes referred to as handles associated with
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the selected anchor. You can change the appearance of the curve by moving the anchor points, 

handles or curve itself (click and drag the curve to move it).

Figure 50: Drag anchor point, handles, or curve to change the appearance of it
  

If you click close to the anchor point, both handles are at the same anchor. Clicking somewhere 

between the curve's anchor points draws one handle at each point.

With the middle mouse button you can add new anchor points to the curve. Press the right mouse 

button to finish the curve.

Figure 51: Handles  

 5.13 FILL

This tool replaces the color of an area, that you click with a foreground color or brush (pattern). Filling 

stops when it cannot pass through groups of dots of different color from the pointed one, or when the 

borders of the selection are reached.

Click the fill icon  or use keyboard shortcut K.

1. Move the mouse pointer inside the selection and point to a color, which should be replaced 

with the foreground (fill) or a pattern. Pattern fill works if the brush is chosen from the pen 

selector, and you have selected a brush (pattern) in the brushes panel.

2. Press the left mouse button. After a few moments, the filled area is displayed.

3. Repeat the steps 3 and 4 as many times as desired and change the foreground color if 

necessary.

 5.13.1 FILL OPTIONS

• Fill to border is used for cleaning scanned images. It fills all pixels, no

matter which color they are, until it hits the background color border.

• Whole image means that the operation works on the whole color area in

the picture, no matter if the pixels are connected to each other or not.

• Threshold defines how similar in color a pixel must be to be filled. Values

can range from 0 to 127. A low tolerance fills pixels within a range of color

values very similar to the pixel you click. A high tolerance fills pixels within a

broader range.

If the Fill option is set to less than 100, program fills the area with a mixture

(like the spray tool) of foreground and background color in the preset ratio.

Figure 52: Fill options
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Figure 53: Initial image Fill at 60% Fill at 25%, Fill at 50%, whole

 image activated
 

• 8-way fill also fills adjacent pixels which are connected on corners. The middle image in Figure 36 

shows the default behavior of the fill tool: if you click in the blue leaf, only the leaf changes the color. 

The image on the right shows what happens if you click in the blue leaf and the 8-way fill option is 

switched on: a green color jumps from the leaf through connected pixel corners to other (blue) parts 

of the flower. The 8-way fill operation checks 8 points around the clicked point. Normal fill could also 

be called 4-way fill, since it only checks 4 points (top, left, right, bottom).

Figure 54: Click in leaf to fill Normal fill 8-way fill
 

 5.14 STITCH TOOL

The stitch tool helps you to draw points in the larger color area to prevent long floats in the fabric. 

Normally, you correct the long floats in ArahWeave, but the stitch line follows the shape of the color 

area, so it is sometimes more convenient to draw points (lines) in ArahPaint to prevent long floats. The

stitching lines can be used also as a design decoration and not only as a long float control.

To use the stitch tool, click its icon  in the toolbox, or use shortcut Shift + K, and click the color 

area, where you want to add stitching points. If you add stitching points in the ground, you should 

work in the repeat mode.

There are different stitch options below the toolbar:

• Direction (left, right, left-right, up, down, up-down) determines which shape

should the stitch line follow

• Length is the distance between two points in the chosen direction.

• Plain weave – if you enable it, then there will be a plain weave pattern 

instead of connected pixels in the stitch line.

• Whole image means that the operation works on the whole color area in the

picture, no matter if the pixels are connected to each other or not.

Figure 56 shows the usage of the stitching tool—all images were made with the

Length of 7 pixels. You can choose the direction of drawing the lines, depending

on the shape of the motif, and the desired effect.

Figure 55: The stitch
tool options
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Figure 56: Stitching points: all possible combinations

 

 5.15 SPRAY

Spray tool draws many randomly distributed dots or selected shapes in foreground color around the 

mouse pointer.

1. Select the icon  or use the keyboard shortcut J. 

2. Set the size and shape. By default, the dot size is one by one pixel. By increasing the number in the 

Line width field, the size of the dot or shape also increases respectively. Figure 57 shows the line 

width numbers with corresponding dots. The pen shape is set to the default shape (circle), but the 

spray tool can be used by other pen shapes too . Note, that the line width 

should be more than 1 for the Shapes icon menu to be available.

Figure 57: The spray dots at various line width sizes

3. Set the number of points (default is 30). A higher number means spray fills in the picture faster.

4. Set the radius of the sprayed area (default is 30 pixels).
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5. As with “analogue” spray, dot density diminishes from the center (of the mouse pointer) to outside

(the From center option enabled), or can be regular across the area (the From center option 

disabled).

6. Move the mouse pointer to the desired spot and press the left mouse button. Drag the mouse to 

other areas, or leave it on the same spot if a stronger effect is desired.

The program will spray dots until you release the button.

Figure 58: Spray with different dot size  

If you disable the From center option, you can also simply achieve different random fill levels of a 

single color, by pressing down the mouse for the desired quantity of time.

Figure 59: Spray from center, and three different intensities of regular spray
 

Figure 60 shows an image drawn with spray, using four different shapes , applied one 

after another.

Figure 60: Using shapes as the spray component.  
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 5.16 MIX COLORS

The Mix tool  with keyboard shortcut Shift+J, is similar to spray, but it 

exchanges existing colors in the image. Use it to soften the border between 

two or more colors, without introducing new colors. The foreground and 

background colors are disregarded in this operation.

 5.17 COLORING PIXELS THAT ARE CLOSER TOGETHER THAN THE DECLARED DISTANCE

BETWEEN THEM 
When you draw the image for the fil coupe, you need to place different motifs (flowers, dots, squares, 

whatever) with a certain distance, so that there is enough space between them in order to cut the long

float threads (the fil coupe). If the distance is too short, then the shearing machine is not able to cut 

off the floats, and such uncut threats look like a defect in the fabric. To get an overview of distances 

between different color surfaces, there are two tools: Color shorter inside and Color shorter outside.

To use the tool, set the distance in pixels first: click the Measure tool icon  and enter the value in 

the X field for the horizontal (weft) direction (if you for some reason want to mark the distance-

shorter-than in the vertical direction, enter the shorter value in the Y field). Then choose the 

foreground color (you can use a new color which you have added to the Palette, or you can use an 

already existing color) which will be used to mark the distance. As a background color, choose the 

color on which you want to apply the distance measurement. Then use Filters > Color shorter outside > 

Horizontal. Program colors all pixels which fall into the declared distance value between pixels of the 

background color.

Figure 62 shows the situation where we want to color the distance between red pixels which are closer

than 50 pixels. We will use Color shorter outside, because we want to paint outside of the red-pixel 

area.

Figure 62: Green is used to color the shorter distance between red pixels.

After applying the command, the program draws lines in the color of the foreground (green) color. 

Figure 61: Mix colors
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Figure 63: Following the implementation of the horizontal color shorter
on the outside. 

 

The Color shorter inside function measures the distance between two pixels on the color surface edges 

(left-right for horizontal, up-down for vertical), and paints all pixels that fall within a certain limit. This 

is mostly used to create fill coupe designs.

Figure 64 shows a situation, where we want to mark all horizontal lines of green pixels, which are 

shorter than 15 pixels. In the option section of the Measure tool set the x value to 15, and choose 

Filters > Color shorter inside > Horizontal.

Figure 64: Applying the Color shorter inside function
 

Now the lines which are shorter than 15 pixels are colored in red and we can use a different weave on 

them than on the green color area.
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Figure 65: The resulting image has horizontal lines shorter than 15 pixels in red.  

6 WORKING WITH COLORS

ArahPaint uses two color spaces: RGB (Red Green Blue) and HSL (Hue Saturation Luminance) in two 

modes:

Color palette (colormap) mode (8 bits per pixel), also known as Indexed color mode, is the default 

mode for new ArahPaint images. This mode allows up to 256 colors. The Gray-scale  mode is a special 

case of  This mode uses up to 256 shades of gray. Every pixel of a gray-scale image has a brightness 

value ranging from 0 (black) to 255 (white). Gray-scale values can also be measured as percentages of 

black ink coverage (0% is equal to white, 100% to black).

True Color mode (24 bits per pixel) uses the RGB color model to specify an intensity to each pixel 

ranging from 0 (black) to 255 (white) for each of the RGB components in a color image. RGB images 

use three color channels, to reproduce up to 16.7 million colors (256×256×256=16,7 million). 

Additionally, ArahPaint supports RGBA, which stands for red green blue alpha. It is the three-channel 

RGB color model supplemented with a 4th alpha channel (transparency). Alpha indicates how opaque 

each pixel is and allows an image to be combined over others using alpha compositing, with 

transparent areas and anti-aliasing of the edges of opaque regions. 

Color values inside ArahPaint are mostly of informational value. They give the designer the overall look

of the picture, dominance of particular colors etc. The final colors of the fabric will be set in 

ArahWeave and will depend on the colors of the yarn and weaves selected.

Some color related functions are available in the Color palette window, while others are located in the 

Colors menu of the main ArahPaint window.



 w w w .ar ahn e .si  Ar ahP ai n t   
U se r  G uid e   

  35

 6.1 CONVERTING IMAGES FROM ONE MODE TO ANOTHER

To convert an image from one mode to another use command Color > Convert and choose either 24-

>8, 8->24 or Grayscale from the menu (shortcut CTRL+J toggles between the True color and the Color 

palette mode).

When converting from true color mode to color palette mode, ArahPaint builds a color palette, which 

contains the list of the colors used in the image. If a color in the original image does not appear in the 

table, the program chooses the closest one or simulates the color using available colors.

 6.2 COLOR PALETTE

Figure 66 depicts the color palette's appearance. It will always show the colors of the currently active 

layer. If the active layer or image is in true color (24 bits per pixel), the palette will not be displayed. If 

you want to see the color palette of a different layer, select it in the Layer palette or in the Active layer 

field (this is faster because you don't have to switch views). Figure 66 depicts a second layer's color 

palette).

 6.2.1 COLOR PALETTE TOOLS

Color palette tools are located at the bottom of the palette area:

 Show used colors–if you press this icon the program will underline 

colors, which are actually used in the image.

 Remove unused colors–will remove all colors from the palette, 

which are not used in the image: light brown 14, blue 15, light violet 16.

 Remove duplicate colors–use this command after you copied one 

color to another, and you don’t want to treat them as separate colors.

 Add color to color palette–if you need a new color in the palette 

press this icon.

 Remove color from color palette–will remove last unused color 

from the palette. If all colors are used, you must use color reduction 

tools instead of this instrument.

The underline number in the color swatch indicates that a color is used in the image. The number in 

italic indicates that a color belongs to a grayscale–Red, Green and Blue values of that color are equal.

 6.2.2 EXCHANGING/PASTING COLORS

You can also exchange or copy colors in the image by using the color palette. First, use left-click to 

select a color in the color palette, then point to another color in the palette and use:

• Middle button click to exchange colors.

• Right button click to copy a color.

Note that when you paste one color to another, you have two swatches of the same color in the Color 

palette. You can still modify each of them. But once you use Remove duplicate colors, all pixels in the 

image with the same color will be reduced to one color, and there will be only one color swatch per 

color in the color palette.

Figure 66: The color
palette of a second layer

(the Active layer field is set
to 2).
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 6.2.3 CHANGING THE POSITION OF THE COLOR IN THE PALETTE

To switch the position of two colors in the palette, click the color in the palette, move the cursor to the

color you want to switch the position with, and press the left mouse button while holding the Ctrl key 

on the keyboard.

 6.2.4 DEFINING TRANSPARENT AND PROTECTED COLORS

Transparent and protected colors are used in layer placement and drawing operations. A transparent 

color means all areas of this color in the layer will become transparent to show the design below the 

layer. Protected colors are colors that can never be overridden by layer placement or drawing 

operations.

Let’s say the layer contains a figure, surrounded by some white space. Pasting such a layer will 

inevitably erase some undesired areas of the main picture. By making the white color transparent, only

the main figure will be placed on the picture.

Figure 70: Transparent
and protected colors

Setting transparent colors (only in a layer; you can't have a transparent

color in the background image): double-click a color tab in the color 

palette window to make that color transparent; a check pattern 

indicates a color state (in Figure 70 white color and red color are 

transparent; the color palette shows the colors in layer 2).

Setting protected colors: double-click the transparent color to change it 

into protected one. A little lock on the color tab indicates the protected 

state (in Figure 70, the protected colors are light blue, green, and 

orange).

Clear transparent/protected colors: double-click the protected color tab

to change it back into a ‘normal’ color. There is also a function in the 

Colors menu (Colors > Transparent colors > Clear; Colors > Protected 

colors > Clear), which enables you to clear settings on all colors in one 

step.

 6.2.5 SETTING FOREGROUND AND BACKGROUND COLOR

Click the foreground or background color square in the toolbox to select which color you want to 

change. Then move the mouse pointer inside the palette region so that the mouse pointer is inside the

desired color, and press the left mouse button to select a new color.

The toolbox also contains an arrow to switch between the Foreground and Background colors. You can

also switch colors by keyboard shortcut X.

Figure 67: Normal layer on top
of background picture

Figure 68: Grey color in the
layer is transparent

Figure 69: Grey color in the
layer is transparent, black color
in the background is protected
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Foreground color Switch foreground / background

Background color

 

You can also select the foreground color from the image, loaded in the main window—move your 

mouse over the desired color pixel and press the Space key. This way, you can quickly change the 

foreground color without having to move the mouse pointer to the color palette window. 

Another way to select color from an image is by the Color picker. Press Shift (mouse pointer will 

change to ) and click the pixel in the desired color.

Some drawing operations, like gradient tools, use both colors

at same time, and you may get interesting effects, if you set 

one of them to be transparent. You achieve this by right-

clicking on a colored tile that represents the color of the 

drawing or the background color. The clicked tile changes the

color surface into the gray-checked pattern .

Figure 71: Setting a background color as
transparent for drawing operations.

 6.2.6 CHANGING A COLOR

To modify the selected color, choose Colors > Edit (Space+Shift), or double-click the foreground or 

background color square on the Toolbox. The Colors dialog box will pop up.

You can modify a color using two different ways:

• Choose color from Basic colors—this color will become your selected color.

• Drag the cursor in  and  to define the color in the color space.

Figure 72: Colors window

 

 6.2.7 SORTING COLORS

After color reduction, the colors are sorted randomly in the Color palette. You can sort colors in the 

color palette by different criteria: Popularity (Ctrl+1), Hue (Ctrl+2), Saturation (Ctrl+3), Lightness (Ctrl+4),

or Similarity (Ctrl+5). To sort colors, choose Colors > Sort colors and select the sort key from the drop 

down menu.
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Figure 73: Sorting by popularity, hue, saturation, and lightness

 

Sorting by similarity works in the following way: choose the color in the palette, to which you want to 

find similar colors. The program puts the color to position 1 in the palette, and sorts the rest of the 

colors from most similar to most different colors to the selected one.

Figure 74: Sorting by similarity to the selected
color

 

 6.3 FINDING FOREGROUND COLOR IN THE IMAGE

Due to similarity between colors in the image, or if there are just a few pixels of a particular color, 

sometimes it is difficult to find an individual color in the image.

If you can’t find the color in the image, choose that color as a foreground color from the palette, and 

press Enter. The pixels of that color will blink. If you press Enter+Shift, the program will position the 

first pixel of foreground color to the top of the program window.
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 6.4 HIGHLIGHTING FOREGROUND COLOR

This function highlights the foreground color, so it is easy to check if the design repeats correctly, or to 

find isolated pixels of a particular color, or just to review the color distribution.

Highlighting depends on the lightness of the foreground color: if it is in the light part, then the rest of 

the image becomes darker, if the color is in the darker part of the specter, the rest of the image 

becomes lighter. 

There are two ways you can use the function:

Pressing the asterisk key ( * ) highlights the foreground color for a few seconds, and then reverts the 

image to its original state.

Pressing the slash key ( / ) toggles the image state from original to highlighted and back.

Figure 75: Highlighting -> the yellow is the foreground color; the image on
the right side shows the "highlighted" view

 

 6.5 CHANGING THE NUMBER OF COLORS (WEAVES)
A scanned image will have more colors, then what you need in a jacquard fabric. The number of colors 

in the picture determines the number of weaves you will use in the jacquard fabric. For most fabrics, 

twenty colors are more than sufficient. There are two ways of decreasing the number of colors used in 

the picture:

• automatic decreasing/increasing function

• user defined reduction of number of colors

 6.5.1 AUTOMATIC DECREASING/INCREASING OF NUMBER OF COLORS

6.5.1.1 TRUE COLOR (24-BIT) IMAGES

It is available through command Colors > Set number of colors. 

The Number of colors in the palette field displays the number of available colors (256). You can change 

the number by typing or by arrows at the right side of the number.
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Click the Preview button to display a preview of the changes

and when you like the result, click the OK button.

By default ArahPaint reduces the number of colors according

to the presence of a particular color. Colors, which cover

smaller areas of the picture, will be converted to the most

similar from the remaining ones (most frequently used

colors).

If enabled, the Color dither mixes the pixels of the available

colors to simulate the missing colors.

The Noise option helps to reduce sharp borders between

colors. It has 12 levels. This option is not available, if the Color

dither option is on.

Figure 77: Original image in true color mode; image with number of colors reduced to 7; image with
number of colors reduced to 7 using a dithering algorithm

 

Scaling dithered images by certain factors introduces numerous artifacts, so it is essential to apply 

dithering after you have scaled the image to its final size.

Figure 78: Dithered image on the left, and same image after resizing it to 90 % of
its original size; you can notice the artifacts caused by scaling

 

Figure 76: Set number of colors window
on true color image (24 bits per pixel)
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6.5.1.2 8-BIT COLOR IMAGES

The Set number of colors window (Figure 79) is slightly 

different, when you reduce the number of colors of indexed-

color images. The Noise and the Color dither options are not 

available.

 6.5.2 USER DEFINED COLOR REDUCTION

If you want to manually control the removal of colors from the picture, use the command Color > 

Reduce number of colors (Alt+C). The appearance and functions of the Reduce number of colors dialog 

depend on the color depth of the image that you want to process.

6.5.2.1 TRUE COLOR (24-BIT)
This function enables you to reduce the number of colors to a 

predefined palette. A color palette is actually a “normal” image in 

indexed color mode (8-bit). The program will use its colors to form 

the group of Selected colors. To load a palette, click the Load or 

Browse button. Loading or browsing work as described in Chapter

4.2 and 4.3.

Figure 81: The original image, the image reduced to four colors from figure 80, and image reduced to
same four colors with “Color dither “option enabled

  

You can achieve the same result using the no-interface function of the number of colors reduction 

directly from the Colors menu:

• choose Colors > Load colormap from image... and load a palette (colormap) from the Image browsers.

• choose Colors > Load dithered colormap from image… and load a palette (colormap) from the Image 

browsers to reduce number of colors with dithering.

Figure 79: Setting number of colors on
palette image (8 bit per pixel)

Figure 80: Reduce number of
colors dialog, showing colors
loaded from palette (image)



42    Chap t e r  6   
 W ork in g  wi t h  col or s

www.arahne.si  

6.5.2.2 8-BIT COLOR

There are two types of the number of color reduction of the 8-bit color (indexed color) images, Color 

and Black and white.

• Color; the user selects the colors, which should remain in

the picture. Selection of remaining colors can be done in

three ways:

1. From the color palette; as you click the color in the

palette, it appears also in the Selected colors section of

the Reduce number of colors dialog. To remove a color

from Selected colors, click it and press the Delete button

on the keyboard.

2. From a picture;

3. By loading a color palette from any indexed color image.

As you click the OK button, ArahPaint converts every color

from image to the most similar color of the Selected colors

group.

• Black and white; the picture will be converted to black and white; you can adjust the threshold 

value.

Picture will be transformed to black and white picture using the threshold value. Every color in the 

picture is first converted to gray, and depending on its gray value it is either converted to black or 

white. If its gray value is lower than the threshold value it will be converted to black, otherwise to 

white. You can play with the threshold value until the desired effect is achieved.

Figure 83: Black and white color reduction using threshold  

Both modes have the Preview button; highly recommended.

 6.5.3 COLOR REMAPPING

Color remapping is another way to decrease the number of colors. This time we will define both colors 

which will remain in the picture, and which colors will be mapped to these colors. Choose Colors > 

Color remapping. The window is split into two areas. In the left one (the Colors in selection table), all 

colors of the selected area are drawn (see Figure 84).

Figure 82: You can choose Selected
(remaining) colors from the current
palette, or by loading colors from

another palette
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Figure 84: Color remapping 

 

The right area displays the Color remapping table. Its first column shows destination colors. Colors, 

which are going to be mapped to destination colors, are on the arrow’s right side (see Figure 85).

Figure 85: Color remapping table  

Procedure:

1. Select destination colors from the color palette; the color is shown in the first column of a new row.

2. In the color mapping table, point to the desired destination color.

3. Go to the Colors in selection area and click every color, which you want to map to a currently active 

destination color. The color will be removed from the selection color area and added to the 

currently active destination color row.

4. Select another destination color and repeat the above two steps.

5. Colors in selection, which are not in the Color remapping table will remain unchanged in the image.

6. The Preview button gives you the preview of the color mapping result, Undo restores to the initial 

condition.

7. If you want to remove a (non destination) color from the mapping table, just click it and it will be 

added back to Colors in the selection area. If you want to erase the entire mapping row, press the 

right mouse button on the destination color (left column in the Color remapping table in Figure 85), 

and select Remove in the pop up menu.
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 6.5.4 INVERTING COLORS

Color inverting means changing each color in an image to its inverse on 

the color wheel. For example, applying the function to a blue object 

(R=0, G=0, B=255) changes the color to yellow (R=255, G=255, B=0). To 

invert colors, choose Colors > Invert and select the color channel you 

want to invert from the menu. 

Figure 86: The invert colors
menu

 Original  All  Red  Green  Blue

 Cyan  Yellow  Magenta  Gray  Saturation

Figure 87: Different invert color modes

If there is a selection in the image, then the Invert function works only on the selection.

Figure 88: Before and after inverting colors in the selection  
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 6.6 SWAPPING COLORS

To access the Swap function, choose Colors > Swap, and 

select a desired mode from the menu. 

The swap colors function has three different modes:

• Color palette (8-bit) – exchanges colors between different color areas – colors in the image remain 

the same, just position is changed.

Figure 90: Images with same color palette
  

• True color mode enables exchanging two or more color channels in the picture.

Figure 91: From left to right: original and results after applying the swap by color channels function

 

• Swapping saturation and lightness

Figure 92: Swapping saturation and lightness
 

 6.7 CONTRAST STRETCH

This tool increases the contrast in the image. It maps the input pixels with the lowest value to black 

(0); and the ones with the highest to white (255). 

Figure 89: The swap colors menu
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Figure 93: Before and after contrast stretch
 

 6.8 KEEP COLORMAP FROM FILE

When you loan an indexed-color image into ArahPaint, by default it displays in the palette only colors 

which are used (visible) in the image. If you want, that it displays also other colors, which are not used 

in the file, but are written in the file’s color table (256 colors), check the Keep colormap from file 

checkbox in the Colors menu. Now the program shows all colors from the image’s color index table, 

even if they are not used for image coloration.

Figure 94: The Keep colormap from file option

If you want to keep the option on in a new instance of ArahPaint, save the setup (Help > Save setup).

7 WORKING WITH CONTOURS

You can access three of the Contour operations (Remove, Thin, Prune) from the Selected colors of the 

Tools menu, while adding and thickening of contours have more options, thus they are controlled 

through the Contour dialog (Tools > Contour).

When you apply any of the contour operations, ArahPaint uses the currently selected foreground color

as the color of the contour.

Note that contour operations will work over the borders of repeat only if the View mode is set to 

Repeat.
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 7.1 THINNING

Thinning serves for reducing the contour line width to one point, while keeping the continuity of the 

lines. Eliminated contour dots are replaced with the color of its neighbors. We want to keep the 

continuity and connectedness of the lines, since we will later fill the picture with colors, and we do not 

want the fill operation to leak. 

To use thinning, choose Tools > Selected color > Thin.

Figure 95: Original image and image after thinning  

 7.2 PRUNING

Applying the thinning may produce some undesired contour dead ends, visible as “twigs”. This 

undesired side effect is more likely to occur in the corners of the original design. The pruning algorithm

looks for such dead ends in the image and prunes them (cut them off). 

Figure 96: Before and after pruning
 

 7.3 ADDING CONTOURS

Add contour will add contour between areas of different colors.

When you want to add a contour between different colors, open the Contour dialog (Tools > Contour). 

Select the color, which you want to outline, from the Color palette, and right-click into the Around 

color square to paste a color into it. The color which will be used as the contour color is currently 

selected foreground color.
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Two options give you control over contour placement:

• Into means that the contour will use the border pixels of

the color we want to outline (in Figure 97, Into is not 

checked, so the contour uses border pixels of the 

neighboring colors).

• All: if enabled, a contour will be drawn on all borders. If 

unchecked, then the Contour dialog gets a new color 

field: With. You set the With color in the same way as 

the Around color by pasting it from the Color palette. 

The contour will be drawn only on the border between 

the Around color and the With color (in Figure 97 

contours will be drawn between orange and green 

color). 

The arrows adjusts the direction of adding the contours. Click an arrow to select it; click the already 

selected arrow to deselect it. You can have selected more directions at the same time. There are three 

additional icons (  ,  ,  ) to the right of the arrow icons. They serve as a tool for quick 

selecting of contour directions (all directions, left-right-up-down direction, diagonal directions). When 

you make all the settings, click OK in the Contour window to apply the contours.

Figure 98 shows the original image on which we will apply some contour operations. The color of 

contour is blue in all examples.

Figure 98: Original image  

Figure 99: Adding contours in all directions (all around dark red)  

Figure 97: The Contour dialog
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Figure 100: Adding contours only in one direction (left of light red on the border with
white)  

Figure 101: Adding contours between two colors (light red and white)  

 7.4 THICKENING CONTOURS

It increases the contour width by user defined number of pixels. You have to set the following 

parameters:

• Contour color (in our example: blue).

• Size, number of dots to be added (in our example: 2).

• Direction (in our example: to the left, right, up and down).

Figure 102: Image before applying thickening
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Figure 103: Thickening contours in one direction  

You can combine this function with protected colors, to ensure that thickening does not affect the 

colors, which you want to keep unchanged.

 7.5 REMOVING CONTOURS

This operation will remove the contour and replace it with 

the neighboring colors. Normally it is used after filling the 

image with colors, and the contour is no longer needed. But it

can be used simply to remove a particular color from the 

image. To use it, choose Tools > Selected colors > Remove.

8 USING LAYERS

When you create or load an image in ArahPaint, the image consists of a single layer (background 

layer). If you are simply retouching the image, you don’t have to create new layers. But if you plan to 

add different designs to your image, layers will make your task a lot easier. Layers allow you to work 

on one element of your image without disturbing the others. Until you merge the layers, each layer 

remains independent.

You can get layers into the image by loading them (they are actually normal images) or by selecting a 

part of the image, thus transforming it into a layer.

 8.1 SELECTING

The selected area is indicated by a dashed or dotted selection border. The dashed line which limits the 

selection in its creation phase looks like this: . In this phase you can still change the 

size of the selected area. But after you move it, or select the Repeat selection checkbox, the line is 

changed to a dotted line , and you can’t change the size of selected area anymore. 

The area outside the selection border is protected while you move, copy, paint, or apply any other tool

to the selected area.

We learned how to make a rectangular selection in Chapter 4.18. We sometimes can't mark the 

desired area with a rectangular selection because the straight borders of the selection cover too much 

or too little of the area. ArahPaint allows you to select non-rectangular areas using freehand selection, 

Figure 104: Before and after removing
the contour
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color selection, a magic wand, and inverted selection. Aside from that, you can alter the selection by 

adding or removing portions of an area. 

 8.1.1 ELLIPTICAL SELECTION

To use the elliptical selection tool, double-click the rectangular selection icon  , which changes to 

the elliptical selection icon  . Drag the mouse from the center of the selection. After you release 

the mouse button, you can still move the selection boundary by moving the mouse pointer to the 

border of the dashed ellipse (from the inside out) until the mouse pointer shape changes to double 

arrow. Now drag the mouse to change the size of the selected area. 

 8.1.2 FREEHAND SELECTION

You can select the area of any shape in the picture. The procedure is very similar to freehand drawing:

1. Click icon  (keyboard shortcut L)

2. Move the mouse pointer to the place where the freehand selection should begin.

3. Press the left button and drag the mouse to draw a freehand selection border. As the mouse 

moves, the dashed line follows the mouse pointer. 

4. To draw a straight selection border, release the button, and click where the segment should 

end. You can switch between freehand and straight line borders as you draw it.

5. Right-click to stop drawing selection. The program automatically connects the first and last 

point by line.

Figure 105: Three modes of freehand selection: freehand, vector, and combined
mode

 

 8.1.3 USING THE MAGIC WAND TOOL

The magic wand tool lets you select a consistently colored area without having to trace its outline. You 

may specify Threshold (color range) before using the magic wand. To use the magic wand tool:

1. Select the magic wand tool 

2. For Threshold, enter a range of pixel values, ranging from 0 to 255. Enter a low value to select 

colors very similar to the pixel you click, or enter a higher value to select a broader range of 

colors (for instance  ).

3. In the image, click the color which you want to select. All adjacent pixels within the threshold 

range are selected. If the Whole image option is on, all pixels within the threshold range in the 

whole image are selected. 

4. You can select 8-ways, which adds adjacent pixels which are connected on the corners to the 

selection. Normal Magic wand mode could also be called 4-way fill, since it only checks 4 

points (top, left, right, bottom).

5. If the selection does not cover the desired area, undo the operations (or press Delete to delete

the selection), adjust Threshold, and try again.
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Figure 106: Magic wand selection: green line indicates
selection's border

 

8.1.3.1 THE WHOLE IMAGE OPTION

When you select the Whole image option, all pixels within the threshold range in the entire image are 

selected.

Figure 107: Magic wand with the Whole image option enabled. 

 8.1.4 SELECTING AREA BY COLOR

You can select all pixels of foreground color using Tools > Select by color (Shift+W). This function only 

works on 8-bits per pixel images.

 8.1.5 SELECTING AREA OF MORE THAN ONE COLOR

You can set the protected colors in the color palette to define more than one color as a criterion for 

selection. All areas in protected colors will become a selection after selecting Tools > Select by 

protected colors.

 8.1.6 INVERTING A SELECTION

Choose Edit > Invert selection to invert your selection to the opposite of its current state. 



 w w w .ar ahn e .si  Ar ahP ai n t   
U se r  G uid e   

  53

 8.1.7 ADDING TO OR SUBTRACTING FROM THE SELECTION

Each selection tool works in the replace mode as a default. In replace mode, a created selection 

replaces any existing selection. 

Beside replace, the following selection modes are supported:

• Add mode, causes new selections to be added to any existing selection. Press and hold the Shift key 

while making a selection to temporarily enter add mode.

Figure 108: Adding to selection: press and hold the Shift key while drawing a second rectangular
selection to add it to the first.

• Subtract mode, causes new selections to be removed from any existing selection. To temporarily 

enter subtract mode, press and hold the Ctrl key while making a selection.

• Intersect mode, causes areas in both the new and existing selection to become the new selection. 

Press and hold both the Shift and Ctrl key while making a selection to temporarily enter intersect 

mode.

 8.2 MOVING LAYERS

To use this function, one of the selection tools    or the move tool  should be 

selected. Move the mouse pointer inside the selection or layer until it turns into a cross with four 

arrows . Then, while holding down the left mouse button, drag the mouse. The layer will follow the 

mouse pointer. To stop, simply release the mouse button. Alternatively, you can move a layer by 

changing the coordinates of its lower-left angle point (see Figure 110). The layer is transparent while 

moving, making precise placement easier. If you don't like this behavior, simply uncheck the Move 

option beneath the toolbox. 

Figure 109: Transparent and opaque layer move

 

If you have more than one layer, the currently selected layer will have a different selection border than

the others. By clicking on a layer while using the move tool , you can make it active. 
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You can use the keyboard arrow keys to move the selection 1 pixel left, right, up, and down for more 

precise layer placement. If you keep pressing Shift while using the arrow keys, you will move the 

selection by 10 points rather than 1. You can also change the layer coordinates above the palette to 

move the layer(see Figure 35).

 8.2.1 PLACING A LAYER TO PREDEFINED AREA

If one of the selection tools is selected, and there is a selection in the 

image, you can move the selection to the edge of the image, or to the 

center of the image using icons in the option area. There are three icons 

for vertical placement (top  , bottom , center ), and three 

icons for horizontal placement ( left  , right  , center  ).

 8.3 LOADING/SAVING A LAYER

Selection can be saved as a layer so you can reuse it in different pictures. Saving layer is identical to 

picture saving with the obvious exception that it only saves the selected area (layer). Use the 

command Save layer as in the File menu and use the same procedure as in chapter 4.6.

Loading a layer is only slightly different from loading a picture. Use the Load layer command (keyboard 

shortcut Ctrl+Shift+L) in the File menu. After you add layers to an image, use the Layers panel to 

manage them.

 8.4 LAYERS PANEL

The Layers panel lists all layers in an image, starting with the topmost layer.

 8.4.1 ORDER OF LAYERS

The order of layers in the Layers panel indicates the order of layers in the

image—the topmost layer in the Layers panel is the topmost layer in the

image. You can change the stacking order of layers by clicking on  or  in

the palette's toolbar (keyboard shortcuts (Ctrl+] or Ctrl+[ ). The background

cannot be moved from the bottom of the layer list.

Figure 111: Layers
panel

Figure 110: Option area
with selection positioning

icons
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 8.4.2 ACTIVE LAYER

Drawing operations only affect the highlighted or active layer. You select a layer to make it active, and 

only one layer can be active at a time. Active layer’s border is different from other layers. To select a 

layer do one of the following:

• In the Layers panel, click a layer to make it active.

• Change the number of the active layer in the field below the palette’s toolbar.

• You can descend through layers by holding Alt+[ or ascend through layers by holding Alt+].

• Select the move tool , and click the selection/layer in the image.

 8.4.3 RENAMING LAYERS

As you add more layers to an image, it’s helpful to rename layers based on their content.

To rename a layer, double-click the layer’s name in the Layers panel. Type a new name for the layer, 

and press Enter.

 8.4.4 DELETING LAYERS

To delete a layer, select the layer in the Layers panel and do one of the following:

• Click the Delete layer icon  at the bottom of the Layers panel.

• Press Delete on the keyboard.

 8.4.5 LOADING LAYERS FROM LAYERS PANEL

The Load layer command is also accessible from the Layers panel: click  in the panel’s toolbar to 

open file selection dialog, or click  to open Browse window, or  to open the New layer dialog 

box.

 8.4.6 VISIBLE LAYERS

In the Layers panel, you can control whether a layer is visible or not. To show or hide a layer in the 

Layers panel, click the eye icon  next to a layer to hide that layer. The icon will disappear. Click in 

the column again to redisplay the layer. 

 8.5 CUT/COPY A SELECTION

First make a selection; then use the command from the Edit menu:

• Cut (Ctrl+X) to cut out the selected area into the buffer. The selected region in the picture will be 

filled with the background color. 

• Copy (Ctrl+C) to make a copy of the selection without changing the contents of the picture.

Cut-copy-paste also works between several ArahPaint programs. It also works with files copied from 

other Desktop programs, such as office and web browsers.

 8.6 PASTING A LAYER

To paste a layer, choose Edit > Paste (Ctrl+V). ArahPaint positions a copy of a layer on the top left area 

of the drawing window. You can move the layer to a desired location.
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 8.7 FLATTEN IMAGE

In a flattened image, all layers are merged into a background image. To merge all layers at once, 

choose Tools > Flatten image (Ctrl+Shift+E).

If you want to merge only the active layer with the background image, do one of the following:

• Click the deselect icon  in the toolbox.

• On keyboard, press Ctrl+D.

• Right-click anywhere on the background image outside of the selection (one of selection tools 

should be active). 

 8.8 OVERLAYING (SUPERIMPOSING) IMAGE (LAYER) OVER IMAGE

Superimposition is the placement of a layer or image over an image, so that colors from layer and 

image are summed up (blended) into new colors (when we normally paste a layer onto image, they 

don’t interact or blend with each other).

There are three different blending modes in ArahPaint:

• Transparent : ArahPaint uses the average color of the top and bottom pixel as the color of 

blended pixel.

• Addition : ArahPaint sums colors of both pixels to get the color of blended pixel. It is useful, 

when colors we get with a transparent blend are quite similar and difficult to distinguish. If you 

blend two relatively light images, the result will be very light and maybe not so useful.

• Subtraction : ArahPaint uses a color difference of both pixels to get the color of blended pixel. 

It is useful to find differences in two images that appear to be the same, because the blended color 

of two pixels of same color is black after subtraction, thus all non-black resulting pixels represent 

the difference in two images.

To use one of these blending modes, select the Paste option, and choose one 

of them; the Transparent mode is selected by default.

Figure 112: Three
modes of

superimposition

If you work on 8-bit images, the images should have quite small number of colors,; otherwise, the final 

number of colors will be too large and difficult to manage. As a result, the program adds M × N colors 

to the number of colors in the ground image, where M is the number of colors in the ground image 

and N is the number of colors in the layer. Finally, it eliminates any duplicate or unused colors. 

Figure 113: Two images that will be combined.  

Figure 114 shows placing a layer (blue flower) over the background image. The background image 

consists of 6 colors, adding blue from the layer we got 7 colors all together in the new image.
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Figure 114: By default, a layer covers area below it completely.

 

Figure 115 shows the same layer, merged with the background image in the transparent mode. We got

6 new colors in the image and the color information of the covered area of the background image was 

preserved.

Figure 115: Transparent-layer overlay

 

 8.8.1 FINDING A DIFFERENCE IN IMAGES USING THE SUBTRACTION MODE

The subtraction pasting mode may assist you in determining the difference between two images that 

appear to be identical but are not. Alternatively, this method can provide proof that two images are 

identical, because subtracting the colors of two identical pixels yields a black pixel.

Figure 116 depicts two jacquard weaves that appear to be identical, but we need to prove that they 

are. 



58    Chap t e r  8   
 U si n g l ay er s

www.arahne.si  

Figure 116: Two weaves appear to be identical.
 

Load the first weave into ArahPaint. Load the second weave as a layer on top of the first weave. Check 

the Paste checkbox and select Subtract as the paste mode. Because of the identical pixels, the result is 

black. In areas where the pixels are not the same, the resulting pixels are white. 

Figure 117: The difference shows up in the white pixels in the image.  
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 8.9 REPEATING A LAYER

The purpose of the Repeat layer function is to lay down many copies of a single layer (selection). In this

way, you can fill the entire picture with layers, laid in a particular order. Choose Tools > Repeat layer 

(Ctrl+Shift+V)—the menu is only available, if there is a selection or a layer in the image.

Figure 118: The repeat layer window

Let’s explain every element of this rather complex window:

• Repeat mode. There are three different repeat modes possible: block , brick , and pillar . 

Picture beside each option explains how layers are laid down.

• Distance mode. The top right icons determine the value of the Distance field. In case the left icon is 

selected (default  ) the distance parameters sets the distance between two consecutive layer 

placements. If the distance value set is bigger than the layer size, this can be aligned inside the 

virtual frame determined by the distance parameter. When the rightmost icon is selected ( ), the

distance parameter sets the distance between the two nearest borders of two consecutive layers (as

depicted on the icon). In this mode the Alignment parameter has no meaning and therefore it is not 

visible.

• Horizontal/Vertical. The window is separated into two identical parts; the layer’s width/height are 

displayed at the top.

• Paste times. Enter the value how many times you want to repeat the layer in each direction.

• Offset sets for how much every row/column of pasted layers is shifted with respect to its 

predecessor. Offset can be relative or absolute. In the first case it can be only a fraction of the 

repeat width/height (1/2, 1/3... 1/n); in the second case, you can change the offset value in pixels. 

Offset setting depends on the repeat mode: when block repeat is selected, offsets are disabled, 

while with brick or pillar mode, only one of the offsets can be set.

• Distance value determines the distance between two consecutive layer placements or the distance 

between the two nearest borders of two consecutive layers (see above). It can also be smaller than 

the size of the layer. If the preview is on, as you change the distance the program interactively 

displays these changes in the layer.

• Alignment sets the alignment inside a virtual frame, when distance parameter value is greater than 

the layer size in the particular direction.



60    Chap t e r  8   
 U si n g l ay er s

www.arahne.si  

• A graphical configuration of the repeat pattern is placed at the right side of the dialog window; each 

repeat is displayed as an arrow. It can assume five different positions, which decide the mirroring of 

the layer:

•  no mirroring of the layer

•  horizontally mirrored layer

•  vertically mirrored layer

•  horizontally and vertically mirrored layer

•  empty space (no layer at all)

• To change the mirroring type, place a mouse pointer over the arrow that you want to change, and

press the left mouse button. The arrow will jump to the next mirror type. Since there are only 5 

mirror types, you will get what you want in a maximum of 4 clicks. If you press the right mouse 

button, it will put the arrow to the default orientation.

• Click the Browse repeat image button to open the Image Browser, where you can load a weave into 

the Repeat layer window. The weave's black and white points serve as a pattern for layer 

placement: a black point indicates layer on, a white point indicates layer off. The layering pattern 

function is extended by using a 5-color image, where pixels of each color represent one position of 

mirroring a layer, allowing you to create complex layering patterns and reuse them later. 

• Preview/Undo button gives the possibility to see the result of settings made, without leaving the 

window. If you are not satisfied, you can change the parameters and try again.

• OK button will confirm the values. You will get a new layer, which you can still move to the desired 

place.

Figure 119: Repeat layer – the distance is equal to the layer size
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Figure 120: Repeat layer in vertical half-drop mode – the distance is smaller than the layer size, so one
layer goes into another; the background color (white) must be transparent.

 8.9.1 LOADING AN IMAGE (WEAVE) AS A LAYERING PATTERN

Assume you want to arrange the design in the style of a satin 5 weave , with each point 

representing a location for a basic design. You can do this manually in the Repeat layer dialog, but it 

takes a lot of clicks to position all 25 elements in the desired order.

Figure 121 depicts a situation in which we want to repeat a layer in a satin5 fashion. To open the 

image browser, click the Browse repeat image button in the Repeat layer dialog. Navigate to the folder 

containing the repeating pattern you want to use and double-click it to open it. The horizontal and 

vertical Paste (times) numbers are automatically set to match the loaded weave's width and height. 

Figure 121: Using an image (weave) to create a repeating pattern. 

When you click OK, the previously single layer is multiplied according to the repeating pattern, 

resulting in the creation of a new layer. If the background image is too small and our goal is simply to 
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create a new image with the Repeat layer tool, you can use Image > Crop to selection to make this new 

layer into a new image. 

Figure 122: Cropping to selection results in a new image from layer.

Figure 123 shows a newly created image, where the basic motif is repeated in the same manner as 

weaving points in the satin 5 weave.

Figure 123: A motif repeated in a satin 5 way.  
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9 TRANSFORM TOOLS

The transform tools let you modify the presentation of the image or the presentation of an element of 

the image, selection or layer.

 9.1 IMAGE SCALING

The Resize image dialog that lets you change the physical size of images or layers or change (reduce or 

enlarge) the area that images or layers cover.

You can access the Resize image 

dialog in different ways:

• From the main menu Image > 

Resize image.

• By clicking the tool icon:  in 

the Toolbox.

• By using the Ctrl+T key 

combination.

Figure 124: The Resize image dialog in ArahPaint

The Resize dialog-box of ArahPaint is divided into four parts:

• The information about the current image size is in the upper right corner.

• The main section, where you change the dimension (in pixels or in physical size in length units (mm,

cm, inches, or percent of original size), and change the density (dpi) of the image. If the associated 

linking chain  is broken  , you can change the Width and Height independently. Click the lock 

icon  beside the value fields you want to prevent from changes.

• Section, where you choose either you will scale the whole image ( ) or just add extra space in 

the foreground color to it ( ).

 9.1.1 CHOOSING THE SCALING MODE

Yo choose the mode of resizing by clicking one of the icons in the scale-mode bar. The first icon selects 

the resize image mode, while the others determines the position of added (or removed) pixels.
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Figure 125: First picture shows the scaling of the image content; others show adding the space to the
image.

 9.1.2 SETTING REPEAT DIMENSIONS

To maintain the original ratio of width to height measurement, make sure that the Constrain 

Proportions option  is enabled. If you want to scale the width and height independently of each 

other, break the chain by clicking on its icon.

Default ArahPaint image resolution is 100 dpi in both directions. But fabrics normally have different 

warp and weft density. One of the most important ArahPaint’s features is the ability to draw images in 

real size mode, which means that pixels are not squares, but rectangles.

Figure 126: The density section of the Resize image dialog

 

Both images in Figure 127 show the same image viewed at a different density.

Figure 127: Vertical density (weft) is lower than horizontal density (warp); density
is the same
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 9.1.3 SCALING THE IMAGE TO MATCH THE NUMBER OF HOOKS AND FABRIC DENSITY

Scaling the image size to match the number of hooks and fabric density can be done in a few steps in 

the Resize image dialog.

1. Load the image and open the resize image dialog.

Figure 128: The default state of Resize image dialog

 

2. Before setting the warp and weft density, break the chain by clicking on it ( ). It changes to the 

broken chain icon ( ). Now you can set each density independently.

3. Set the unit of the density (Threads/inch, Threads/cm) and the density of the fabric.

Figure 129: As you set the density, the width and height values change too.

 

4. Close the chain again, so that the width and height will be calculated in the proportion to the 

density. Lock the density—it means that it will remain the same, when you change other parameters.
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Figure 130: Before changing the width and height

 

5. Set the new width dimension in pixels (usually it matches the number of hooks). Accordingly, the 

height is changed, as well as physical dimensions (you can choose different units from the drop-down 

menu).

Figure 131: Setting the new width

 

6. If the calculated number of pixels in height doesn’t exactly match the size of the weave you want to 

use in your design, you have to change it. Broke the chain, so that you can change the height 

independently and type in the new value. Click the OK button.
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Figure 132: Correcting the height (number of wefts) in design

 

7. The final result is a re-sampled image in a new size.

Figure 133: The resulting image of resizing

 

 9.2 ROTATING AN IMAGE (LAYER)
You can rotate any selection (layer) around its center. After you have created or loaded a layer, choose

Image > Rotate image...(Shift+R) or press  in the toolbox, and a rotation dialog will pop up (Figure

134). (

Rotating an image turns it around its center point, while flipping an image inverts it across its 

horizontal or vertical axis.

To rotate a layer, selection, or image do one of the following:

• Move the pointer outside of the bounding border, and then drag the mouse while pressing the left 

button.

• Specify an angle of rotation in the degrees field.



68    Chap t e r  9   
 T r an sform t ool s

www.arahne.si  

• Change the position of the angle slider.

• Click one of the fixed angle rotation buttons (45 degrees, 90 degrees,...).

Figure 134: Setting a rotation angle

 

The Filter option works in the same way as during image resize (chapter 9.1). When an image is 

rotated, an interpolation method is used to calculate the new rotated image. The more sophisticated 

the method, the more details of the original image are preserved. The interpolation method is set on 

the Filter cascade menu.

• Resizing without any filter (None) is the fastest, but least precise method.

• Bilinear is the medium-quality method. The color of each pixel is computed as the average color of 

the four closest pixels in the original image. This gives a satisfactory result for most images and is a 

good compromise between speed and quality.

• Bicubic The color of each pixel is computed as the average color of the eight closest pixels in the 

original image. This usually gives the best result, but it naturally takes more time. Use it when you 

are rotating images in true color mode.

OK will confirm the settings and rotate the image, without closing the dialog, so you can continue 

adjusting the settings, and Close will close the dialog box.

 9.3 ALIGNING THE IMAGE

After scanning, you should check whether the image is aligned horizontally and vertically to window 

borders. If not, you should rotate the whole image to achieve alignment. To do this, choose Image > 

Rotate Image. Draw a line, which follows the orientation marks (could be a line, two crosses, etc...) in 

the image.

Figure 135: Drawing the alignment line
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The program rotates the picture and informs you about rotation angle, so the line which you have 

drawn (red line in Figure 135) becomes straight. To confirm alignment, click the OK (or Close button) in

the Rotate image window.

Figure 136: Preview of aligned image

 9.4 DUPLICATE TOOL

The duplicate tool enables you to repeat an image or part of an

image in a fast way. All duplicate tools, except Mirror X – 1 and 

Diamond, work similar to the Drawing in repeat (if the New 

picture option is enabled) tool, or the Repeat layer tool.

Figure 137: The Duplicate menu

You can use it in a horizontal (Image > 

Duplicate X) or vertical (Image > 

Duplicate Y) direction.

Figure 138: Original image, and image after mirroring, using
the duplicate tool in X and Y direction 

 9.4.1 MIRROR X – 1 DUPLICATE

The mirror X -1 function works the same as a “normal” mirror, except that the last pixel of the image is 

omitted from the mirrored image.
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Figure 139: The original image, and image after Mirror X and
Mirror X-1

 

 9.4.2 DIAMOND DUPLICATE

The diamond duplicate tool rotates an image for 45 degrees and doubles the image size in the defined 

direction (x or y).

Figure 140: The original image, and image after diamond duplicate in x
direction

 

 9.5 SHRINKING AN IMAGE (OR LAYER)
The Shrink function (Image > Shrink) divides image size by 2 in the desired direction (x or y). It is 

alternative to image resizing, but it is accessible with a single click from the menu, which is faster then 

opening the resize image dialog and entering new size values.

Figure 141: The original image, and image after shrinking

 

 9.6 MIRRORING AN IMAGE (LAYER)

Use  button for mirroring of the layer along the vertical axis, or  button for mirroring along 

the horizontal axis, or  for mirroring along the diagonal. Non-rectangular layers can also be 

mirrored.

 9.7 INSERTING OR REMOVING AREA FROM IMAGE OR LAYER

The Insert or remove area function lets you add or remove space at any position in an existing image.

To use the Insert or remove area function click  icon in the Toolbox.

Depending on the mode (adding or removing) and direction, you should check one of the four Type 

icons in the Insert or remove area dialog:
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•  adds horizontal area

•  adds vertical area

•  removes vertical area

•  removes horizontal area

You have two possible ways to define adding or removing:

• By straight line (default—area is rectangular).

• By freehand line —added area follows freehand

drawn line.

You have three different choices to determine an

appearance of the added area:

• Color: inserted area is in a currently selected foreground

color (a default setting)

• Area: inserted area is a duplicate of the area,

determined by Position and Number of pixels 

• Line: inserted area is the copy of the horizontal or vertical line (can be straight or freehand drawn) 

at chosen Position, multiplied by the Number of pixels value.

 9.7.1 INSERTING OR REMOVING RECTANGULAR AREA

You can insert or remove the rectangular area in two ways:

• By entering parameters:

1. Set the pixel position, where you want to add or remove space.

2. Decide whether the space will be added before or after pixel position.

3. Number of pixels that you want to add or remove.

4. Click OK.

• By drawing with mouse:

1. Place the mouse pointer on the position, where you want to add or remove the area. 

2. Left-click, hold the button, and drag the mouse. The number in the Position field shows the 

position, where you have clicked, the blue rectangle indicates the size of added or removed 

space (Figure 143). Number in the Number of pixels field is changing as you drag a mouse and 

showing the numbers of pixels you will add or remove.

3. Release the mouse button; a new area is drawn in the selected foreground color.

Figure 143: Add area with mouse  -  After releasing the mouse button

 

 9.7.2 INSERTING OR REMOVING IRREGULAR AREA

Sometimes it is not possible to add the rectangular area without changing the original image. In this 

case you can draw a freehand line, and ArahPaint will add or remove the required number of pixels 

before or after the drawn line.

Figure 142: Insert or remove area dialog
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After selecting Type (adding or removing, direction), check the freehand drawing line icon  in the 

Insert or remove area window. Enter the Number of pixels that you want to insert. Draw the line, 

where you want to insert the area (Figure 144). Before reaching the edge of the image, click the right 

mouse button, so the program connects a line to the edge. Click OK in the Insert or remove area 

window. You can repeat the operation by clicking the OK button.

Figure 144: Inserting an irregular area. The newly inserted area is in foreground (red) color

  

 9.7.3 INSERTING LINE OR AREA

The inserted area is by default in the color of the current foreground color, but you can also insert the 

area from the image itself. It works in two modes:

Area – it inserts chosen area determined by Position and Number of pixels

Line – it duplicates chosen line (Position)

Figure 145 shows an image, where we inserted 48 pixels of foreground color, which followed a 

freehand drawn line. Obviously, in this case it doesn’t make a lot of sense, it would be better to use 

the Line option or Area option.

Figure 145: Inserting an irregular space – the Color mode
 

Figure 146 shows inserting of an area, which is a duplicate of 48 pixels below the drawn line.

Figure 146: Inserting an irregular space – the Area mode

 

The inserted area in the right-hand side image in Figure 147 is 48 repeats of the area determined by 

drawn line (see the Number of pixels field). 
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Figure 147: Inserting an irregular space – the Line mode

 

 9.7.4 AUTOMATIC INSERTION OF IRREGULAR AREA (FINDING A PATH)
Figure 148 shows an image which we want to scale to width of 1260 pixels to match the size of our 

Jacquard loom, but without modifying the size and appearance of basic motif. So we need to add 60 

pixels of background color somewhere. But leafs are tight packed and it is difficult to draw a line where

we want to add pixels. But there is the Find path function in the Insert/remove area dialog, which, if 

possible, finds a path between motifs automatically.

Figure 148: We want to increase the width from 1200 to 1260 pixels.
 

We will add two times 30 pixels to get the final width of 1260 pixels. Usually we add the area with 

another color so we can easier review the result. Select the Find path option, set the number of pixels 

to 30 and click in the image where you want to add area.



74    Chap t e r  9   
 T r an sform t ool s

www.arahne.si  

Figure 149: The Find path icon in the Insert/remove area dialog.
 

We repeat procedure somewhere else in the images adding additional 30 pixels. The end result is the 

1260 pixels wide image with the motif size of the original image.

Figure 150: Final result

 

The Find path tool works only in one direction, adding or removing vertical area. If you need to apply 

the function in horizontal direction, first rotate an image , and then use the Find path tool.

 9.8 UNSKEW TOOL

Using the unskew tool lets you fix the geometry of a layer, which is distorted by perspective. The tool is

explained in the next three figures. This is useful for pictures where you could not use the scanner.
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Make a rectangular selection  around the object which

you want to unskew.

Click the Unskew tool icon .

Drag the corners of selection to the corners of the

distorted part of the image.

Click OK in the Unskew dialog box. The selection becomes a

normal rectangular layer.

 9.9 CHANGING THE START OF REPEAT

Sometimes, after the picture is put into repeat, it is desirable to move the starting point of the repeat 

up/down or left/right. This function is accessible through icons  and  in the toolbox. The first 

tool moves the starting point in horizontal direction, while the second in vertical direction.

The procedure is:

1. Select one of the icons.

2. Move the mouse pointer to the new starting point in the selected direction. The cut point is 

the middle of the mouse pointer, not its edge!

3. Left-click.

Figure 151: Make a selection

Figure 152: Adjust section borders

Figure 153: Unskewed selection
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 9.10 SHIFTING THE IMAGE OR LAYER

To access the Shift tool, click the Measurement tool icon . Among 

others, there are four icons with arrows, which determine the direction 

of shifting. For shifting left or right, enter the number of pixels in the X 

field and click the left or right arrow, for shifting up or down, enter the 

number in the Y field, and click the up or down arrow. You can repeat 

the operation as many times as you want.
Figure 154: The shift tool

and its parameters

 9.11 TILTING THE IMAGE OR LAYER

To access the Tilt tool, click the Measurement tool icon . The tilt tool shifts every next line of 

pixels (set the width of the line in the X field for the horizontal tilt  , or set the width of the 

line in the Y field for the vertical tilt  in the image (layer) for the preset number of pixels in 

the Value field. You can repeat the operation as many times as you want.

Figure 155 shows the basic use of the tilt function. Default values are set to 0 (actually it is the same as

there are set to 1). You just have to click the tilt icon . An important feature of the tilt tool is that 

after applying it, the image keeps the repeat.

Figure 155: The initial image; the initial image after tilting for one pixel and after tilting for one pixel
three times, and the repeat view of the last image

By setting the X (or Y) and Value, you can change the tilting preferences to tilt a block of pixels instead 

of a single pixel. Figure 156 explains how to do it.

Figure 156: First image shows the settings: x=8, Value=4; A is the initial image, B is the image after
clicking once the tilt left icon, C is the image after clicking four times (4x4=16).

 9.12 SPLITTING THE IMAGE

To access the Split tool, click the Measurement tool icon . The split image tool lets you split the 

image by divisor, that you enter in the X field for vertical splitting, or in the Y field for horizontal 

splitting. The image size does not change with this operation. If the divisor is set to two, then the odd 
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line of pixels are in the first half of the image, and the even lines are in the second part of the image. 

To split the image in the vertical direction click icon , to split in the horizontal direction click icon

. The opposite operation of splitting is merging. Normally, when we split the image and do some 

operation on the split image, we merge the image back to its original appearance. To do this, click the 

icon  for vertical merging, and icon  for horizontal merging.

Figure 157 shows the use of the split tool. The task is to draw stitching points with the Stitch tool  

on every fourth line in vertical (Y) direction. The fastest way is to use the Split tool. In the Y field, enter 

the divisor number (4), and click the split vertical icon. The image is divided into four parts. Use the 

stitch tool on the fourth part, and then merge the image to its original form.

Figure 157: The use of the split tool: the initial image is on the left, image after splitting,
image after applying stitching, image after applying merging is on the right

 

 9.13 FINDING A REPEAT IN AN IMAGE

As the name suggests, the Find repeat function helps you to find repeat, if there is any, in an image. It 

is very useful on scanned designs from books, or on images you get from other sources.

There are two variants of the function: Find repeat and Find exact repeat. The former is used to find a 

repeat in scanned images, usually in jpeg format, where repeats have similar appearance, but pixels 

are not necessarily exactly of same color. The latter is used to extract the repeat from Jacquard cards 

or images that were already prepared for weaving, but for some reason contains more than one 

repeat. Program finds the repeat only if all pixels of each repeat are exactly the same.

Figure 158 shows a design we got from a design book, which consists of more than one repeat.
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Figure 158: Four repetition of design show that it doesn't repeat

 

To reduce a design to only one repeat, choose Tools > Find repeat. If the program finds a repeat, it will 

draw a selection line around it.

Figure 159: A selection line around the repeat

 

After cropping to selection, use View > Repeat to check if a design repeats correctly.

Figure 160: Viewing at four repetitions shows that design repeats
correctly.
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10 BRUSHES

A drawing tool with an enabled brush option tool lets you paint with a 

pattern. You can load the brush or create new brushes, when you need, 

and you can use a part of an image to create a custom brush. To draw with

a brush, choose it from the pen mode selector – click the icon below the 

line-width field, and choose the stamp icon , which represents the brush

mode (we use a brush as a stamp a lot in ArahPaint, thus the stamp icon 

for the brush mode).

If there are no brushes in the brushes panel, the brush icon mode is not 

present in the pen modes menu.

Figure 161: Choosing the
drawing-with-a-brush

mode.

 10.1 BRUSHES PANEL

A brushes panel displays all stored, loaded or created brushes. Once you have

created a brush or loaded it into a palette, it will be stored and available for

other ArahPaint programs, until you delete it from the palette.

You can use it also as a temporary storage of picture motifs, copying them from

one image to the other, without the need to name them and save them as a file.

To get a brush into the program, click the Brushes panel tab . There are two

ways to place a brush into the palette:

• Open the Browse brushes window  from the Brushes panel toolbar, and

load a brush (image) by double-clicking (any image may become a brush).

• Create a layer, and send it to the brushes panel by using Tools > Layer to

brush, or Keyboard shortcut >, or by clicking  in the Brushes panel toolbar.

If you need to change the brush, send it to the main working space either by:

• Tools > Brush to layer

• Keyboard shortcut <

• Clicking  in the Brushes panel toolbar.

A brush will become a layer. When you finish with editing, send it back to the

Brushes panel.

If the Keep checkbox is checked, then the previous version of the brush will

remain in the palette.

You can also edit a brush in a new ArahPaint window; select a brush in the

palette, and click the Open with ArahPaint icon  in the Brushes panel toolbar.

It does exactly what it says on the icon tool-tip—a new ArahPaint window will

appear with the selected brush loaded. Now you can edit it, save it, and load

again in the previous program.

Figure 162: Brushes
panel
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To delete a brush from the panel, click its icon to select it, and then click the delete icon  in the 

Brushes panel toolbar, or press Delete on the keyboard.

 10.2 DRAWING OPERATIONS WITH BRUSHES

You can use the selected brush to modify the behavior of drawing operations. By combining them you 

can achieve interesting effects. You can also use transparent colors on the brush, and protected colors 

in the drawing area.

 10.2.1 FREEHAND DRAWING

A freehand-draw tool with a brush will fill the drawn area 

with a brush instead of the foreground color. The figure

163 shows a line drawn with a brush from the Brushes 

panel displayed in Figure 162; a line width is set to 5.

Figure 163: Freehand drawing with brush

 10.2.2 STAMP MODE

The freehand draw has the Stamp option. If you click in the 

image, the program will draw the brush at that position. The 

program also moves the brush along with your mouse, so you 

will know precisely where it will be drawn, even before you click 

to draw it in the image.

 10.2.3 DRAWING FILLED SHAPES

You can easily draw motifs 

in repeat using a  brush.

Figure 165: Rectangle and ellipse drawn with a brush

Figure 164: Drawing in stamp mode
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 10.2.4 SPRAY

Spray can also be used with a brush.

 10.2.5 FILL WITH BRUSH

You can use the Fill tool to cover the area of a particular color with a selected brush. By default, the 

starting point of the brush mapping is where you click the area (if the image size is divisible by the 

brush size; otherwise, the starting point is shifted for the reminder of that division). You can modify 

the starting point by adjusting the Offset coordinates.

More controllable brush mapping is possible in the Absolute mode, which is achieved by selecting the 

Absolute checkbox. he brush mapping then begins in the image's lower-left corner. You can modify the

coordinates of the starting point by setting the Offset numbers.

Figure 167: Selecting the fill tool and choosing a brush  

Figure 166: Brush used with spray
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Figure 168: Filling the area with the selected brush  

Figure 169: Repeat the Fill with brush with different offset settings  

11 INSERTING TEXT

To insert text into the image, click the text icon button  (keyboard shortcut T), and you will get the

font selection dialog.

The procedure consists of four steps:

1. Enter the text you want to use in the image.

2. Choose a font from the Font scrolled list.

3. Choose a style from the Style scrolled list

4. Choose a size from the Size scrolled list.
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Figure 170: Inserting text
 

When you click the Insert button, the program will overlay the image with the text you entered. The 

foreground color is used for text, while the background color fills the rest of the space. If you want, 

you can change the background color to Transparent and enable Antialiasing. You can change the 

alignment if you have more lines. You can adjust the space between characters by changing the 

Spacing setting. After you've placed a text layer in a picture, you can still change all of these settings 

because if you click the Insert button again, the new layer will replace the previous one.

The number of fonts, styles, and sizes available is determined by the operating system.

12 REPEATING AN IMAGE

The jacquard design is frequently made up of identical building blocks arranged in columns or rows, 

with some of these blocks being mirrored (horizontally or vertically). When placing blocks on a regular 

basis, it is more convenient to first define the pattern of repetition (number of blocks, orientation of 

each block, repeat mode—half-drop or block repeat), then draw or edit a single block-image while the 

program repeats the operations for all the other blocks. The advantage of this method is that you can 

modify the building block interactively and immediately see how each drawing operation changes the 

entire repeated image.

To open the tool for manipulating images in the repeat mode, select Image > Drawing in repeat.  Please

keep in mind that this tool only works on background images. It has no effect on any layers that are 

present in the composition. Use the pasting functions described in Chapter 8.9 to repeat layers.

This tool can be used in three ways:

5. Checking how the image connects to its left, right, top, and bottom sides, and eventually 

correcting the border area if there are mistakes in the image's transition from one side to another.

6. Making an image from a basic image by mirroring and half-dropping it, and then converting the 

repeats into a single image.

7. Combining points one and two. 
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 12.1 SETTING THE PARAMETERS OF REPETITION

First use the Drawing in repeat command (Ctrl+D) in the Image menu and the following window will 

appear.

Its content is similar to the multiple paste

window (the repeat layer tool), with some

modifications.

On the top is a graphical configuration of the

repeat pattern; each repeat is displayed as an

arrow or empty space. It can assume four

different positions, which decide the 

orientation of the repeat:

•  no mirroring of the repeat

•  horizontally mirrored repeat

•  vertically mirrored repeat

•  horizontally and vertically mirrored

repeat

•  empty space (using it makes sense only

if you create a new image from multiple

repeats and empty spaces)

To change the mirroring type, place a mouse pointer over the arrow that you want to change, and 

press the left mouse button. The arrow will jump to the next mirror type. Since there are only 5 mirror 

types, you will get what you want in a maximum of 4 clicks. If you press the right mouse button, it will 

put the arrow to the default orientation.

• Repeat mode allows three different types of repeat alignment: block , brick  and pillar .

• Offset is active only when brick or pillar mode is selected. It can be either fixed (fraction of 

width/height of the repeat—like half drop) or absolute, where you input the offset in pixels.

• Paste (times): Number of repeats in a row/column.

• The number below Horizontal and Vertical displays the total size of the picture. Two exclamation 

signs (!!) beside the number denotes picture size mismatch due to the wrong offset.

• New picture: Program will create a new picture made of repeats according to parameters set in this 

window. This is usually the last step in the process of creation of a compound image.

• If you click the Random button, the arrows will be oriented at random. You can keep clicking to get 

different layouts of arrows. 

• The Reset button does exactly what it says: it resets the arrows to their default position .

• Preview enables live preview of he repeating as you modify the layout.

 12.2 HALF-DROP REPEAT

Figure 172 shows a design made with the Drawing in repeat tool that starts with a blank image. Then 

you set the repeat mode to half-drop and load and paste a motif into the image. Check the New 

picture checkbox before leaving the Drawing in repeat dialog to create a new image from the repeating

blocks. 

Program draws the delimiter lines between individual repeats if you enable View > Draw delimiter lines 

(Alt+G).

Figure 171: Drawing in repeat window
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Figure 172: Example of a half-drop design

 

 12.3 DRAWING/EDITING THE PICTURE IN THE REPEAT MODE

First change the view type with the command Repeat (R) from the View menu. Perform drawing 

operations. Every operation is repeated on every repeat, which forms the image. You can draw over 

the border of repeat. Some contour operations require the Repeat view in order to be correctly 

applied across the border.

The most common usage of drawing over the borders of repeat is when you correct the transition 

between right and left, or top and bottom of the repeated image.

Figure 173 shows design, repeated two times. Red circles mark mistakes at the junction of the repeat. 

Figure 173: After scanning, usually there are mistakes on the repeat borders
 

To correct errors, simply draw across the repeat. 
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Figure 174: Drawing across the borders of repeat

 

 12.4 CONVERTING IMAGE OF SEVERAL REPEATS INTO A SINGLE IMAGE

Check the New picture checkbox in the Drawing in repeat window once the individual repeat has been 

drawn to the point where it perfectly joins the others, and after you have set the repeat mode, the 

orientation of individual block (actually current image). Following confirmation, the new image will be 

composed of all repeats based on the settings.

Figure 175: The image is denoted by a red rectangle. The remainder is a preview of the repeating mode. 
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Figure 176: After confirming the setting in the Drawing in repeat dialog, a new image is created.

 

 12.5 USING THE RANDOM OPTION

The Random option in the Drawing in repeat dialog randomizes the orientation of the blocks. You can 

get a design based on this random layout by selecting New picture.

Figure 177: A red rectangle represents a single repeat. The orientation of all repeats is the same. 
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Figure 178: When we click the Random button, the arrows are placed at random, resulting in a
completely new pattern. 

Figure 179: Another use of the Random function.
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 12.6 LOADING AN IMAGE OR A WEAVE AS A LAYERING PATTERN

Assume you want to arrange the design in the style of a satin 5 weave , with each point 

representing a location for a basic design. You can do this manually in the Repeat layer dialog, but it 

takes a lot of clicks to position all 25 elements in the desired order.

Figure 180 depicts a situation in which we want to repeat an image in a satin5 fashion. We'll use the 

image browser to choose a weave, which will serve as a model for design repetition. To open the 

image browser, click the Browse repeat image button in the Drawing in repeat dialog. Navigate to the 

folder containing the repeating pattern you want to use and double-click it to open it. The horizontal 

and vertical Paste (times) numbers are automatically set to match the loaded weave's width and 

height. 

Figure 180: Using an image (weave) to create a repeating pattern. 

The image is multiplied in accordance with the repeating pattern. Select the New picture option and 

click OK. Figure 181 shows a newly created image, where the input image is repeated in the same 

manner as weaving points in the satin 5 weave.
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Figure 181:Creating a new picture

Drawing in repeat supports up to 100 by 100 repeats, allowing for the use of more complex weaves, as

shown in Figure 182.

Figure 182: Another example of a weave being used as a repeating pattern. 
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13 USING FILTERS

A filter is a type of tool that takes an input layer or image, applies a mathematical algorithm to it, and 

returns the input layer or image in a modified form.

The filter functions in ArahPaint keep the repeat and respect protected colors. 

With the exception of the top two Filters menu items (Averaging and 

Despeckle), all Filter menu entries use the Measure tool  options to 

adjust the Filter properties. Filter properties are configured in three fields: 

Value, X, and Y. The filter behavior is controlled by one, two, or all three 

values, depending on the type of filter. 

There are also three additional options (not all three are applicable for all 

filters):

• use all colors from the palette  (normally only the foreground color 

is used)

• use variable size of effect 

• use a filter as a gradient .

With some filter operations you get a satisfactory result only, if you repeat them several times. To do 

this, use Filters > Repeat last operation or use keyboard shortcut Ctrl + F.

A filter function is typically only the first step in the design preparation process. When combined with 

other functions such as the protected colors function, a contour tool, and other filter tools, you can 

quickly create interesting effects. 

 13.1 NOISE

The noise filters add noise to the image or to the active layer. The image noise is the random variation 

of color information in images. It is generally regarded as undesirable, but sometimes it produces 

interesting effects in the fabrics.

To access function, choose Filters > Noise, and then you have three different options (directions):

• Horizontal and Vertical

• Horizontal

• Vertical

To change the Noise parameters, click the Measure tool icon . The noise related parameters are X 

and Y. There are several ways of using it.

Noise with parameters x = 0, y = 0 (default values; ) makes a single pixel noise, using all 

unprotected colors from the Color palette. If you use it in the vertical or horizontal direction, you get 1 

pixel wide color stripes. Since the stripe distribution is completely random, sometimes there are 2 or 

more pixels wide stripes. But, if you change either x or y to 1, then ArahPaint takes care about the 

repetitions, so that line width remains 1 all the time, while the colors are always alternating.

Figure 183: The filter
options
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Figure 184: Horizontal -vertical, vertical, and horizontal noise at x= 0, y=0
 

If you change x and y values to anything different from 0 or 1, and use Horizontal and vertical noise, 

you get rectangles of different colors with preset x and y dimensions (Figure 185). If you use only 

Vertical or Horizontal Noise, you get lines with length between x and y value.

Figure 185: Horizontal-vertical, vertical, and horizontal noise at x= 8, y=4, value=1
  

 13.2 SELF AVOIDING MOTIFS

This function adds color motifs which avoid each other in the image for the maximum possible 

distance. To use it, choose Filters > Self avoiding motifs, and select a motif shape from a menu. You can

select the square (rectangle), diamond, circle (ellipse), triangle, line, cross, and the diagonal cross.

To set the amount and size of added motifs, click the

Measure tool icon  to access the option fields. 

In the X field, enter the size of shape in pixels in 

horizontal direction, in the Y field, enter the size of 

shape in pixels in vertical direction, and enter the 

number of motifs in the Value field. If the both X and

Y fields are set to 0, the program adds single pixels 

to the image.

Figure 188: Motifs at same values (X=8, Y=16), but different shapes  

Figure 187: The self
avoiding motifs shapes

Figure 186: Self
avoiding motifs

options
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Figure 189: Rectangular self avoiding motifs 

 

 13.2.1 MIRRORING AND FLIPPING IN THE MOTIFS FILTERS

The last three tools in the Self avoiding motifs menu - horizontal mirror , vertical mirror , and flip

 work in different way then ordinary motifs – when you choose a motif (shape), the program draws 

shapes in the image, but when you choose one of the mirror operations, it applies mirroring on the 

randomly selected image parts of the image. The size of parts is  determined with X and Y parameters 

in the filter options, and the number of parts is defined in the Value field. In order to work, the image 

must have some pattern already, because if you apply mirror operations to a single-color rectangle you

always get the same single color rectangle.

 13.3 RANDOM MOTIFS

This filter uses the same interface (shapes and values) as self avoiding motifs. As the name indicates, 

instead of a self avoiding algorithm it uses random placement of motifs.
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Figure 190: Random placement of motifs
 

 13.4 PLACE MOTIFS

The Place motifs filter fills a color surface with a selected motif in such a way that one motif never 

touches another motif. If you repeat the operation, and at some point fill all available space, filter 

stops to work. It is not limited just to the surface of one particular color – you can use protected colors

to control where the filter will operate.

Figure 191: Placing the motifs, using the diamond shape, variation in size from 15 to 40 pixels, using all
colors from the palette; image at left shows result after applying the filter ones at value 300; image on

right shows result after repeating operation until the all space was filled.

Variable effects can be achieved by using protected colors. Figure 192 shows placing circles into 

APAINT caption. First, you have to protect the background color (white), and place circles into the 

caption. Then protect the color of the caption and the color of circles, add a new color to the palette, 

and place a motif of that color into the background. At the end, change the color of the caption into 

the background color.
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Figure 192: Placing motifs using protected colors

 

 13.5 IKAT

Ikat is a type of weaving where the warp, weft 

or both are tie -dyed before weaving to create 

designs on the finished fabric. If you want to 

get a similar look on an ordinary jacquard 

fabric, you have to draw a distorted image. To 

use the automatic ikat function, which will 

randomly move lines or columns of an image 

for the determined value, press the measure 

tool icon  , set the offset in the Value field 

in pixels of the Measure tool, and use Filters > 

Ikat from the menu. You can choose between 

Horizontal, Vertical and Horizontal and vertical 

direction. You can repeat the operation as 

many times as you want.

Figure 193: Setting the value and choosing the ikat
direction
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Figure 194: Before and after applying the Ikat effect – the image in the middle with the value of  5, and
image in the right hand side with the value of 12.

 

If you have protected colors in the image, the program will not create the effect on that color. The Ikat 

filter supports usage of protection on the colors.

Figure 195: Before, and after applying the ikat effect – blue and green are protected on the far right
image .

 

 13.6 MARBLE

The marble effect is similar to ikat. The difference is that the shifting of lines (or columns) is correlated 

– every next line jumps just for one pixel to the left or right – so direction is random, but the move is 

just one pixel. Beside value, there is another parameter you can change to get different effects – X for 

vertical filter, and Y for horizontal filter. With this setting, the direction of shifting is not random 

anymore, it will have the same direction till it reaches the Y (or X) number. Then it will change the 

direction (the right side image in Figure 196).

Figure 196: The original image, the same image after applying the marble filter with Value=20 Y=0, and
the same image after applying the marble filter with Value=20 Y=15.
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 13.7 ZIGZAG

The Zigzag filter creates a zigzag pattern from the image. The number and height of zigzags depends on

the settings of filter options (X, Y, and Value) and the direction (Horizontal, Vertical, Horizontal and 

Vertical).

Figure 197: Using the Zigzag filter  

• X: determines number of zigzags, that filter creates in the image in horizontal direction (actually up 

or down; to get zigzag up and down, you need to set the number to 2, or it should be the even 

number). Images in Figure 198 were made with value 8 (it creates 4 peaks).

• Y: determines the number of zigzags, that filter creates in the image in the vertical direction (left or 

right)

• Value is the peak-to-peak amplitude in pixels. If the value is set to 0, the program takes the whole 

image height as the amplitude value.

Figure 198: Initial image, image filtered with value of 0, image filtered with value of 20  

 13.8 WAVE

The wave filter is similar to zigzag; it creates waves in the image. As with the zigzag filter, click the 

Measure tool icon  to access the option fields.

• X: determines the number of waves that filter creates in the image in the horizontal direction 

(actually up and down). Images in Figure 198 were made with value 4.

• Y: determines the number of waves, that filter creates in the image in the vertical direction (left and

right)

• Value is the peak-to-peak amplitude in pixels. If the value is set to 0, the program takes the whole 

image height (width) as the amplitude value.
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Figure 199 shows the wave filter effect: the second and the third image were made by using the value 

of amplitude 8, and x and y value 12. The last image is just a repeat view of the third one, showing that

the filter doesn’t break the repeat, if the x or y values are divisible by 4.

Figure 199: Initial image, wave filter applied in vertical direction, wave filter applied in horizontal
direction, and the repeat view of former image   

 13.9 MIX

It mixes color between two (or more) adjacent color surfaces. You can select the horizontal or vertical 

mix, or both. Works similar to spray across the whole image. Protected colors are also kept intact.

As with other filters, click the Measure tool icon  to access the option fields:

• X: determines the width in pixels of the area between colors, where the program creates the “mix” 

effect. The horizontal mix filter uses the X value.

• Y: determines the height in pixels of the area between colors, where the program creates the “mix” 

effect. The vertical mix filter uses the Y value.

Figure 200: Initial image horizontal mix vertical mix horizontal-vertical mix

 13.10 THE CORALS FILTER

This filter tool emulates the coral growth. You need to have some starting pixels or objects in the 

image, from which the corals will grow. You get nice results, if you start with the Self avoiding motifs 

filter (Chapter 13.2) and use these motifs (pixels) as the coral growing area.

Corals grow from the objects colored in the background color, and are 

drawn in the current foreground color. As with other filters, click the 

Measure tool icon  to access the option fields, and set the value to 

something like 500 or more. Select Filters > Corals , and from the menu 

choose the coral type. Each type uses different criteria to attach the 

points. Normally you would need to repeat the operation a few times 

(Filters > Repeat last operation; keyboard shortcut Ctrl+F). Figure 201: The corals
menu
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Figure 202: Corals drawn with foreground color around background color; value set to 9000
 

Figure 203 explains the six types of corals in ArahPaint. All corals in the image grow from the center 

point, and were drawn at the same value settings.

Figure 203: Six types of corals

 

 13.11 GRADIENT

This filter tool fills the selected area with a gradient 

blend of the foreground and background color. In the

menu, you can choose the direction, either vertical, 

or horizontal.

Figure 204: The color gradient between
foreground (white) and background color (blue)

Figure 205 shows the result of the gradient filter, 

using the same settings as in the previous image, 

except that we have used the bidirectional mode (

). In one repeat, gradient goes from foreground 

color to background color and back. We get a 

seamless repeating image. Figure 205: The color gradient, bidirectional
mode
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If you enable the All colors option  then the 

gradient uses all colors, which lie between 

foreground color and background color in the 

current color palette.

Figure 206: The color gradient, which uses all
colors between foreground color and

background color

The gradient filter also works on images in true color 

mode.

Figure 207: Gradient in true color mode

You can modify the angle of the gradient effect by entering the parameter in the Value field in the 

Filter options. For instance, if you enter 45, you will get the gradient line from the lower left corner to 

top right corner of the image.

Figure 208: Gradient at value 20, 45 and 90

 13.12 THE CONTOUR FILTER

This filter allows you to create contours around color areas. Every time you repeat the operation, a 

new contour is added to the previous one. Protected colors are kept intact. 

As with other filters, click the Measure tool icon  to access the option fields:

• X and Y: determines the width in pixels of the whole contour area (marked as A in Figure 209). If 

you want that the width remains the same after every step, then set both X and Y to that same 

number; if X and Y are different, the width varies between value X and value Y.

• Value: determines the width of the contour(marked as B in Figure 209). If the variable size option is 

disabled ( ), then the width of the contour is the same all the time; otherwise it varies from 1 to 

the number set in the Value field.

•  If checked, all colors from the palette are used for drawing contours. 

Figure 209 shows the basic usage of the contour filter. Contours are drawn in the foreground color 

(cyan) – the width (Value) is set to 6, the rest of the contour area is drawn in the background color 

(white) - both X and Y are set to 16 pixels, which means that the whole “contour area” will have a 

width of 16 pixels.
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Figure 209: Top figure shows the original image; the contour filter applied once; the contour filter
applied twice. Main image shows the filter setting and the magnified area from the upper image.

14 CLEANING UP THE PICTURE

Like other input methods, scanning produces some noise, which is present in the digitized image. 

Noise is usually visible as single dots or groups of dots mainly on the border between two colors.

 14.1 AVERAGING

To reduce noise on the whole image, choose Filters > Averaging. If you have an image with layers it will 

work just on the active layer.

The Averaging tool works in the following way: it searches through the image for dots (a dot may be 

formed from more than one pixel) that differ from the ones in its neighborhood, and change them to 

predominant color in the surrounding. It can be applied several times to achieve the desired result. 

Some information will be inevitably lost in this process.

Figure 210: Before and after averaging 

 

 14.2 AVERAGING WITH PARAMETER

Sometimes, the color surfaces get jagged edges after image resizing or color reduction. To make edges 

regular, set the parameter of averaging from 2 to 7 (higher number means a stronger degree of 
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averaging). Set the parameter in the Line width field. If the image consists only of lines and edges, you 

have to color the surfaces, since the algorithm distorts or even removes single pixel wide lines.

Figure 211: Before and after averaging with parameter 4

    

 14.3 DESPECKLE

The despeckle option works similarly to averaging, but you can control the pixel removal by setting the

"neighbor" parameter. The neighbor parameter is set in the line width field.

The isolated pixels have a parameter value of 1 (they have no neighbors). Every neighbor who touches 

the pixel diagonally increases the parameter by one, and every neighbor who touches the pixel 

straightly increases the parameter by two. The program deletes all pixels whose neighbor value is less 

than the specified value.

The despeckle function can be used on all colors in the image (Filters > Despeckle > All) or just the 

foreground color (Filters > Despeckle > Selected).

The "neighbor" parameter value is illustrated in Figure 212. When the line width is set to 1, the 

program removes isolated pixels that do not have any neighboring pixels of the same color. The 

greater the value, the greater the area removed by connected pixels of the same color.

Figure 212: Examples of neighbor value
 

Figures from 213 to 215 show the despeckle function in practice.

Figure 213: Image after color reduction
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Despeckling with parameter set to 1 (Figure 214) removes only isolated points; there are still some 

mistakes on the borders between colors.

Figure 214: After despeckling with parameter set to 1

 

Increasing the parameter to 5 and applying the function again removes the rest of the border pixels.

Figure 215: After despeckling with parameter set to 5
 

 14.4 RUBBER

ArahPaint's rubber tool  is a variant of averaging. It works on the user defined circle area. It takes 

pixels from a wider circle (Average diameter in tool’s options), calculates the most popular color and 

draws that color into smaller circle’s pixels.

Figure 216: Rubber tool in 8 bits per pixel color mode
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In true color mode it works in a slightly different way. It takes pixels from a wider circle, calculates the 

average color, and draws that color into smaller circle’s pixels.

Figure 217: Rubber tool in true color mode  

 14.4.1 BORDER CLEANUP

Border cleanup changes various color pixels into one of two adjacent colors. If the smooth option is 

on, it will also make the border regular.

Figure 218: Rubber options, with border cleanup and smooth options on  
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15 PRINTING A PICTURE

Select the Print picture command from the File menu to open the Print 

picture dialog. A repeat of the image starts from the bottom of the 

printout area / drawing area in the window. Top of the window displays 

the currently selected printer, printer mode and density (see Chapter

15.1 how to change them). If you have several printers connected to the

computer, you can change the print queue using the cascade menu on 

the top right (the menu in Figure 219 is colored blue).

Left, Upper border, Print width, and Print height parameters need no 

special explanation. Their values are in millimeters. If the Setup in 

ArahWeave is set to the imperial measurement system, then the sizes 

will be displayed in inches. 

Repeats in width and Repeats in height show how many repeats of the 

picture fit into the print width and height respectively. ArahPaint 

calculates these values on the basis of picture sizes in pixels and repeat 

size in mm.

Fit to page toggle button will modify the magnification factor to a value, 

which will fit at least one repeat on the print width and height.

One repeat toggle button enables you to print just one repeat of the 

image.

Title enables printing of title (file name) on the top of the image.

Landscape enables changing from default portrait to landscape printing.

It is easy to see if the print settings are correct by using Preview.
Figure 219: Print picture

window

 15.1 CHANGING PRINTER SETTINGS

To change the printer and its settings,

press the Setup button to open the Setup

dialog (Figure 220). 

You can change the following parameters:

• Printer type

• Printer mode

• Printout quality

• Printing to file

Their values are shown in the boxes

below respective scrolled lists.

First select a printer by clicking its name

on the list. Then select the print mode, which depends on the selected printer. There are at most three

different printing modes:

• True color

• Color dithered

• Black & white 

Please note that color pictures cannot be printed with black and white mode selected. In such cases 

ArahPaint will issue an error message. The quality of the printout is defined by dot density (dpi – dots 

per inch). The higher the density the better the quality of the printout. High values may slow down 

printing.

The printing can be redirected to a file when the printer is not available on the computer or on the 

network. In this case, check a toggle button labeled Print to file and enter a printout filename in the 

box below the scrolled lists.

Figure 220: Printer setup window



1 06    Chap t e r  16   
 Ac kn ow l ed gme nt s

www.arahne.si  

16 ACKNOWLEDGMENTS

Program written by Matjaž Gutenberger, Dušan Peterc, Christian Linhart, with contributions by 

Nedeljko Stefanović, Peter Kovář, Ognjen Djukić, Nejc Janhar.

Porting to Ot4 toolkit by Nebojša Obradović and Milan Miletić; porting to the Qt5 toolkit by Christian 

Linhart. Porting to Windows was sponsored by Stäubli. The first Qt3 version of ArahPaint4, developed 

by Matjaž Gutenberger, used parts of Motif based ArahPaint3, written by Simon Weilguny.

Manual written by Anton Gregorčič, based on ArahPaint2.8 manual written by Simon Weilguny.

Front page and shortcuts design by Ana Bertoncelj.

Picture credits:

Tessilbiella: Figure 2, 12, 13

Arazzo: Figure 12, 13

Lanificio di Sordevolo: Figure 67, 68, 69

Cyprus, Kourion, photo by Dušan Peterc: Figure 151, 152, 153

F. Scanzio, U. Pedrazzo: Intrecci e Strutture dei Tessuti, Biella, 1988: Figure 135

Ljubljana, Oct 2, 2023


	1 Introduction
	2 Program’s appearance
	2.1 Setting the language
	2.2 Measurement system (metric or imperial)
	2.3 Saving other user-defined settings
	2.3.1 Changing the default load and save location
	2.3.2 The image browser preferences
	2.3.3 Saving the default window’s size
	2.3.4 Other settings


	3 Suggested sequence of steps
	3.1 Drawing a design on paper
	3.2 Scanning the drawing

	4 Basic operations
	4.1 Creating new images
	4.2 Loading images into ArahPaint
	4.3 Loading files from Image Browser
	4.3.1 Image preview
	4.3.2 The Details View
	4.3.3 Browsing subdirectories
	4.3.4 Renaming files
	4.3.5 Deleting files from ArahPaint
	4.3.6 Optimizing png and jpg files

	4.4 Opening image from desktop or file manager
	4.5 Loading recently used files
	4.6 Saving a design
	4.7 Importing vector images (SVG, PDF) into ArahPaint
	4.8 Clear image
	4.9 Undo / Redo
	4.10 Magnifying or reducing the view
	4.10.1 Fit to window
	4.10.2 Alternating between current zoom and 100% zoom
	4.10.3 Grid
	4.10.4 Anti-Aliasing

	4.11 Ruler
	4.12 Displaying the RGB color values
	4.13 Guides
	4.14 Measure tool
	4.15 Cross-hair cursor
	4.16 Pan tool
	4.17 Using the tools
	4.18 Selecting a rectangular area of a design
	4.19 Cropping to selection
	4.20 Trimming picture or layer
	4.21 Deselecting a layer
	4.22 Deleting a layer

	5 Drawing operations
	5.1 Line width
	5.2 Drawing modes
	5.2.1 Pen mode and Fill(%)
	5.2.2 Gradient drawing modes

	5.3 Pen shapes
	5.4 Drawing straight lines
	5.4.1 Parametric drawing

	5.5 Drawing perfectly horizontal, vertical or diagonal lines
	5.6 Freehand drawing
	5.7 Polygon drawing
	5.8 Drawing rectangles/squares and ellipses/circles
	5.9 Draw a line across the image
	5.10 Drawing arcs
	5.11 Drawing curve
	5.12 Bézier tool
	5.13 Fill
	5.13.1 Fill options

	5.14 Stitch tool
	5.15 Spray
	5.16 Mix colors
	5.17 Coloring pixels that are closer together than the declared distance between them

	6 Working with colors
	6.1 Converting images from one mode to another
	6.2 Color palette
	6.2.1 Color palette tools
	6.2.2 Exchanging/pasting colors
	6.2.3 Changing the position of the color in the palette
	6.2.4 Defining transparent and protected colors
	6.2.5 Setting foreground and background color
	6.2.6 Changing a color
	6.2.7 Sorting colors

	6.3 Finding foreground color in the image
	6.4 Highlighting foreground color
	6.5 Changing the number of colors (weaves)
	6.5.1 Automatic decreasing/increasing of number of colors
	6.5.1.1 True color (24-bit) images
	6.5.1.2 8-bit color images

	6.5.2 User defined color reduction
	6.5.2.1 True color (24-bit)
	6.5.2.2 8-bit color

	6.5.3 Color remapping
	6.5.4 Inverting colors

	6.6 Swapping colors
	6.7 Contrast stretch
	6.8 Keep colormap from file

	7 Working with contours
	7.1 Thinning
	7.2 Pruning
	7.3 Adding contours
	7.4 Thickening contours
	7.5 Removing contours

	8 Using layers
	8.1 Selecting
	8.1.1 Elliptical selection
	8.1.2 Freehand selection
	8.1.3 Using the magic wand tool
	8.1.3.1 The whole image option

	8.1.4 Selecting area by color
	8.1.5 Selecting area of more than one color
	8.1.6 Inverting a selection
	8.1.7 Adding to or subtracting from the selection

	8.2 Moving layers
	8.2.1 Placing a layer to predefined area

	8.3 Loading/saving a layer
	8.4 Layers panel
	8.4.1 Order of layers
	8.4.2 Active layer
	8.4.3 Renaming layers
	8.4.4 Deleting layers
	8.4.5 Loading layers from Layers panel
	8.4.6 Visible layers

	8.5 Cut/copy a selection
	8.6 Pasting a layer
	8.7 Flatten image
	8.8 Overlaying (superimposing) image (layer) over image
	8.8.1 Finding a difference in images using the Subtraction mode

	8.9 Repeating a layer
	8.9.1 Loading an image (weave) as a layering pattern


	9 Transform tools
	9.1 Image scaling
	9.1.1 Choosing the scaling mode
	9.1.2 Setting repeat dimensions
	9.1.3 Scaling the image to match the number of hooks and fabric density

	9.2 Rotating an image (layer)
	9.3 Aligning the image
	9.4 Duplicate tool
	9.4.1 Mirror X – 1 Duplicate
	9.4.2 Diamond duplicate

	9.5 Shrinking an image (or layer)
	9.6 Mirroring an image (layer)
	9.7 Inserting or removing area from image or layer
	9.7.1 Inserting or removing rectangular area
	9.7.2 Inserting or removing irregular area
	9.7.3 Inserting line or area
	9.7.4 Automatic insertion of irregular area (finding a path)

	9.8 Unskew tool
	9.9 Changing the start of repeat
	9.10 Shifting the image or layer
	9.11 Tilting the image or layer
	9.12 Splitting the image
	9.13 Finding a repeat in an image

	10 Brushes
	10.1 Brushes panel
	10.2 Drawing operations with brushes
	10.2.1 Freehand drawing
	10.2.2 Stamp mode
	10.2.3 Drawing filled shapes
	10.2.4 Spray
	10.2.5 Fill with brush


	11 Inserting text
	12 Repeating an image
	12.1 Setting the parameters of repetition
	12.2 Half-drop repeat
	12.3 Drawing/editing the picture in the repeat mode
	12.4 Converting image of several repeats into a single image
	12.5 Using the random option
	12.6 Loading an image or a weave as a layering pattern

	13 Using filters
	13.1 Noise
	13.2 Self avoiding motifs
	13.2.1 Mirroring and flipping in the motifs filters

	13.3 Random motifs
	13.4 Place motifs
	13.5 Ikat
	13.6 Marble
	13.7 Zigzag
	13.8 Wave
	13.9 Mix
	13.10 The corals filter
	13.11 Gradient
	13.12 The Contour filter

	14 Cleaning up the picture
	14.1 Averaging
	14.2 Averaging with parameter
	14.3 Despeckle
	14.4 Rubber
	14.4.1 Border cleanup


	15 Printing a picture
	15.1 Changing printer settings

	16 Acknowledgments

