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1  OVERVIEW

ArahDrape is  a  texture  mapping  software,  developed to help  weavers,  designers  and retailers  in

making a presentation of their fabrics on products. 

By using ArahDrape, you will be able to show the looks of your fabric on a shirt, tie, jacket, sofa, table-

cloth,  bed  linen  or  whatever  the  final  product  may  be.  You  will  be  able  to  present  the  whole

collection of your fabrics, and answer many mix-and-match “What if?” questions at almost zero cost.

What if we rotate this pattern by 45 degrees? Can you make it 20% smaller? The picture will answer

the question in no time. 

Figure 1: ArahDrape working area

 

1.1 TYPE OF FILES IN ARAHDRAPE

You will  deal  with three different file  types,  each of them having  its  own load dialog  or browse

window. These types are:

• Models (images in common graphical formats; the default location is data/img/models).

• Textures (images in common graphical formats; the default location is data/img/textures).

• Projects  (Arahne  proprietary  file  format;  extension  is  .drape;  the  default  location  is

data/drape).

To change the default location for ArahDrape's files, open ArahWeave   and choose Help > Save
setup. Click the Set default path button, and type in the new folder path. Click OK in the Set default

path dialog. Confirm the change by clicking the OK button in the Save setup window.
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Figure 2: Setting the default folder location  

1.1.1 MODELS

A model is the initial image for creating the ArahDrape project. Basically, it is a picture of a model or a

product, with fabric areas in white or in single, preferable light color, with visible shades. You can use

the image in GIF, PNG, JPEG, TIFF, or BMP format. ArahDrape keeps the shades and the ambiance of

the original photo, and just fills up the fabric areas. If the fabric in the model has a strong pattern like

diagonal lines, there is a chance that the old pattern will be noticeable in the new image and that it

will decrease its overall quality. Therefore it is better to remove or reduce the pattern effect using

some photo editing software, for example ArahPaint.

1.1.2 TEXTURES

ArahDrape covers regions in the model by repeating the texture image, which replaces the original

surface. So the texture should be seamless—it means that the image edges should be aligned, when

the image repeats itself. All fabric textures created with ArahWeave will automatically be seamless.

If you get a texture of the fabric by scanning or photographing a fabric, ArahPaint provides a set of

tools for fixing the texture and finding or correcting a repeat. But sometimes, like for the image on

Figure  3, is better to take another photo of a fabric and take care about a light and shadow, than

spend time on correcting it.

Figure 3: A fabric photo displayed in ArahPaint in the repeat view mode. ArahDrape will also
repeat the pattern in the region. The draped image will show mistakes on repeat borders.
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Figure 4: The pillow on the right was mapped with the original
photo, while the one on the right was mapped with the

corrected texture.

 

1.1.3 PROJECTS

A project file consists of model file (normal image), texture image files, lines which delimiter regions

in a model, and vectors, which determine the draping of the texture over each region. Beside these,

the project file contains the magnifying factor of textures and their angle of rotation. Using this data,

the program renders the image of the project in the main ArahDrape window.

1.2 VIEW MODES IN ARAHDRAPE 
You can view the project in four different view modes: 

• Image displays only the image of the model.

• Region  displays the image and the border lines between regions (when they are present in the

project).

• Region and Drape displays the image, textures and the border lines between regions.

• Drape displays textures over the original image.

To change the view mode, use the View menu in the menu bar.

Figure 5: The same project viewed in four different view modes

1.2.1 ZOOM LEVEL

There are four ways to change zoom level in ArahDrape:

• Choose the Zoom menu, and click the desired zoom level from the list. There are entries from 1:10
to 10:1. 1:8 means zooming to 12,5%, 1:1 means 100%, and 1:10 means 1000%.

• Press key + to zoom in, or press key – to zoom out.

• Press the Ctrl key on the keyboard and roll the mouse wheel up or down.
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• If you press any number from 0-9 on the keyboard, you will change zoom directly to that level (1

means 100%, 6 means 600%, 0 means 1000%).

The current zoom level is indicated as a % value in the title of the main window.

1.2.2 FIT TO WINDOW

Zooms in or out until the entire project just fits in the ArahDrape window. Select it from the Zoom
menu, or use keyboard shortcut Ctrl+0.

1.3 LOADING FILES INTO ARAHDRAPE

Each of the three file types – projects, models and textures, has its own Load file (browse) dialog.

These browse dialogs look similar, so we will describe just one of them, the Load model dialog.

To open the file browser, use Models > Load model.... Thumbnails (reduced-size versions of pictures)

of image files are displayed to identify each image. Do one of the following to load the model into the

ArahDrape window:

• Double click on the thumbnail of the image.

• Select the thumbnail of the image and then click OK or press Enter.

Figure 6: Browsing images

 

The labels below thumbnails have different background colors. Currently selected image has a text

label in yellow. Bi-level (black and white) images have a light gray background of the filename area,

and true color images have a background in light pink. Color palette (8-bit) images use the white

label background.

The meaning of icons in the toolbar is described in the table below.

one directory up

back

forward

reload

default directory

switch to detailed view, switch to icon view
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sort order

find image

create new directory

rename image

delete image

open selected image with ArahPaint4 (same as the middle mouse button click on an

image icon)

Filter option allows you to search for particular images by  size x,  size y,  size xy,  number of colors,

date of creation, and file name. If you use the file name filter, the program will interactively change

the display to show you only the pictures, which match the search filter. In this way you will find your

image very quickly.

To preview an image, position the pointer over a thumbnail and click with the right mouse button.

The Preview window in a full screen mode will appear.

Figure 7: Full screen preview of the selected image

 

The arrow keys (← ↑ → ↓) move the image in the window in the desired direction. Default view size

is set to 100%, the repeat view is on. Press F on the keyboard to fit the image in the window. Use +
and  – to zoom in or zoom out (or  1,2,3,...  for zoom 100%, 200%, 300%...).  R toggles between  the

single image view and the repeating image view. The Page Down key loads the next image, the Page
Up key loads the previous one. The Home key loads the first image in the directory, the End key loads

the last one. 

To close the Preview window, press the Esc key, or click with the right mouse button in the window.

When you navigate to the image directory for the first time, the image browser has to recognize

images  and create image thumbnails  from the images.  When you scroll  up or  down, it  instantly

creates icons for files which appear in the visible area. If the files are big, the thumbnails’ creation

time may increase.  That might cause some lag while  scrolling.  To avoid  a lag—press  Alt+Q.  The

browser will create all thumbnails at once, even for files, which are not in the related display area.

Note, if you have a lot of files in that folder, you may have to wait some time for the program to

finish  creation  of  thumbnails.  The  next  time,  when  you  enter  that  image  directory,  the  image

browsing will be much faster, because the thumbnails were already created.
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1.3.1 THE DETAIL VIEW

The image browser also supports the detail view, which displays each file or folder on a separate line,

as a file name followed by information about the image: Name, Date, File type, Size x, Size y, Colors,

dpi X, dpi Y, File size. You can sort images by any of these criteria. To change the sort key, click on the

title of the list. A selected column will be highlighted in yellow. To switch from icon to detailed view,

click the detail view icon ; to go back, click the browse icon .

Figure 8: Detailed list view of images

 

1.3.2 BROWSING SUBDIRECTORIES

ArahDrape’s browsers have a capability of showing files in sub-directories. This is very useful, when

you search for a file, and you don’t know in which directory you have saved it.  If  there are sub-

directories in your parent directory, then the Image browser displays the “leafless tree” icon  at

the top right corner of the window (in the same line as a directory path). To display all files from sub-

directories, click the tree icon. It changes to the “tree with leaves and fruits” icon  , which means

that the Image browser shows all files from the parent directory and its sub-directories. If the image

is in the sub-directory, then the name of the sub-directory appears in the image icon.

You should be careful when using this option, since it may take a very long time to finish and display

the images. Especially if you enable it at the start of your disk (/). The program will not crash, but it

will  read all  the files on your hard disk, and this can take a lot of time. You should only use sub-

directory browsing of directories which actually contain the images.

2  USING ARAHDRAPE

2.1 INTRODUCTION

We can roughly divide ArahDrape work flow in two different tasks:

• Creating a project file from scratch; from input model image, correcting regions, changing (adding,

removing) the vectors, and adding or replacing textures.

• Applying textures and colors to existing projects.
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2.2 CREATING A PROJECT FILE

2.2.1 LOADING A MODEL IMAGE

Open ArahDrape, choose Models > Load model... from the menu bar (keyboard shortcut Ctrl+Shift+O).
This will open the image browser, from which you can load a model.  Thumbnails of image files are
displayed to identify each image.
Do one of the following to open the image in ArahPaint:

• Double-click an image file.

• Select an image file and then click OK, or press Enter.

Figure 9: ArahDrape's main window with a model loaded

2.2.2 SETTING THE MODEL SIZE

Different cameras and software save out their images at different default resolutions. A photo of a

chair does not contain the information about its real size, you have to set it by yourself. There is a

simple tool in ArahDrape, which enables you to set the physical size of the model.

Choose Regions > Set size. In the Set size dialog, choose the measurement unit, and draw a line on

the section of the model,  for which you approximately  know the length.  Then type in the “real”

length of that line, and press the OK button. 
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Figure 10: Setting the physical size of the model  
If  the  model’s  real  size  has  been  set  correctly,  then  the  zoom  level  of  the  texture  will  be  scaled
automatically to correct value.

2.2.3 CREATING A REGION

A region is an area within the image, where you want to overlay a fabric texture or change a color.

To draw a region:

1. Choose Regions > New > Vectors, or simply click on the icon  in the toolbar. It changes into ,

which indicates that you are in a region drawing mode.

2. Click to create the first point of the region.

3. Position the pointer where you want the first straight segment to end, and click. Continue clicking

to set endpoints for subsequent segments.

4. Close the border:

• Position the pointer over the starting point, and click.

• A right click will close the border from your current position to the starting point.

Figure 11: Drawing region boundaries  

When the region is finished, the View mode changes from Regions to Regions and Drape.

There are other functions for editing region border:

• If you have made a mistake and want to delete just the last point(s), which you have drawn, press

[Esc] key on the keyboard. It will work several times.

• If you want to add a point into an already finished region border, point a mouse cursor where you

want it, and click with the middle mouse button.

• To delete a point in the already finished region border, click on it with the middle mouse button.

• To move a point, click it and drag it to a new location.
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• To move a common point of two or more regions, press and hold the Shift key and click a point

and drag it to a new location.

• To delete the whole region, click on a region and press [Del] key on the keyboard, or use Regions
> Delete from the main menu.

You must draw region borders for all areas – including the holes in regions, like the buttons. Once you

have drawn all the borders, you will be ready to load the texture, which you want to drape over the

area.

2.2.4 USING TRANSPARENT PNG IMAGE AS A MODEL

Normally we use a transparent image as a model to omit the background from the image and place

the model in the spotlight. We can also use only a part of the model in each project, and join them

together  later in a final image using the web browser or other image manipulation program. The

advantage of using transparent images is that you don’t need to precisely outline the regions, which

border  the  transparent  region,  because  the  textures  placed  on  a  transparent  area  are  invisible

anyway.

Figure 12: One of advantages of transparent PNG images: no need to precisely draw the outline
region border

2.2.4.1 SETTING THE COLOR OF THE TRANSPARENT REGION

The Transparency sub-menu of the View menu allows you to select the

way  transparency  is  displayed  and  saved  in  formats  which  do  not

support transparency, for example JPEG. You can choose between the

default gray check-board, and solid black, gray or white.

Figure 13: Choosing the
view mode of  transparent

area

Figure 14: Same project, viewed at different transparency view modes

2.2.5 CREATING A REGION, WHICH SHARES A PART OF THE BORDER WITH OTHER REGIONS

On many occasions, the limits of one region will border to another region. You will need to draw the

points of your new region on the same points of the already existing region. Otherwise they will not
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join correctly  and some pixels  will  “shine” through the borders.  But  ArahDrape can automatically

draw the area border vectors along the existing area.

When you start drawing a new region, which will  have some part of a border common with other

regions, you will soon reach the first common point with the existing region. Click on it, and then click

the last common point. Press the spacebar, and the program will  automatically  draw new vectors

along the common vectors between the last two points. Obviously, there must be a connected path

of vectors of other areas from one point to the other, or the program will not know what to do. Then

continue drawing the region, and finish it with the right mouse button.

Figure 15: Drawing common border between regions: press the Space key after you have connected
the first and the last common point

The default color of the active region’s line is blue, while the color of unselected regions’ lines is red.

The default color of lines can be changed in Files > Preferences....

2.2.6 TYPES OF REGIONS

Each region can be any of three types: 

• Color  you specify the solid color for the region.

• Texture   you specify a texture image file  for the region.  You can’t switch to Texture type

before you load at least one texture image file into the Textures bar.

• Hole  region is the same as in the model file.

You change the region type by pressing on the Region type icon in the ArahDrape’s toolbox on the top

right. When you create a new region, the default type is Color.

Figure 16: Same region as color, texture and hole  
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2.2.7 PROPERTIES OF THE REGION

If  the  region  type  is  Texture,  then  it  gets  two  more  properties:  the  zoom  level  (Scale),  the

horizontal/vertical ratio and the rotation angle (Rotate). Both properties are saved in the project file.

2.2.8 LOADING A TEXTURE INTO THE TEXTURE BAR

Texture can be any picture in a supported graphical format (PNG, TIFF, GIF, JPEG). It will probably be

in repeat, but you may also use textures, which do not repeat themselves. If you scan the fabric, you

will probably spend some time creating a seamless repeat. You can use ArahPaint for this purpose.

The textures can be loaded into ArahDrape using Textures > Load texture....

Figure 17: Loading a texture from the image browser  
To load a texture into ArahDrape, double click its icon. The Load texture window will

not close, so you can load a different texture, if you don’t like the result. Textures will

be displayed on the texture bar on the right, just below the toolbar. If you want to

unload the texture from the program, you can either click on it and load a different

texture in its place, or press [Del] on the keyboard to get rid of it. This will not delete

the texture file; it will just remove it from ArahDrape.

You can load up to 200 textures in the Textures bar. When you save the project files,

only the textures, which are used in the project, are saved in the project file.

Figure 18:
The textures

bar

2.2.9 USING PANTONE® FASHION + HOME TCX COLOR SYSTEMS AS TEXTURES

Arahne supplies digital color library PANTONE® Fashion + Home TCX Color System with its software.

To use it in ArahDrape, you first need to export colors in ArahWeave. Open ArahWeave (icon  on

the Desktop), and switch to  Expert mode (Mode > Expert in the main ArahWeave window). Then
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open  the  Edit  colors window  using  Fabric  > Colors,  and load a color library  (usually  PANTONE®

Fashion + Home TCX Color  System).  Choose  Files  >  Save  colors  as  images.  When you open the

Texture browser, there will  be the folder with  the same name as the color library file and all  the

colors from the library will be in graphical format, so you can load them as textures in ArahDrape.

Figure 19: Saving colors as images  

2.2.10 APPLYING A TEXTURE TO THE REGION

To apply a texture to the region:

1. Select the texture in the texture bar with left mouse click.

2. Point to the desired region and copy it with right mouse click.

Figure 20: Copying a texture from texture bar to the region  

You can also copy a texture from a region, which already has a texture: use the left mouse button to

select  a  textured region,  and  the right  mouse button to copy a  texture  to  another  region.  This

operation also copies the region zoom level (Scale) and Brightness. 

Figure 21: Copying a texture from region to region  

2.2.11 REPLACING SAME TEXTURE IN ALL REGIONS AT ONCE

If your drape model contains many regions, like the sofa from our example, you will quickly become

tired of  clicking on regions with the right mouse button to apply a different texture. One would like
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to copy the new fabric texture to all regions, which currently have the same texture. To achieve this,

click on the group icon  in the toolbar. It will change itself to , so that you know that you are in

“group” mode. From now on, you can use a single click (right mouse button) to copy texture to all

regions with the same texture. You can then disable the group to change the region type individually,

if you wish.

Figure 22: Replacing single and group of textures  

2.2.12 CHOOSING A COLOR FOR THE REGION

If a region is of color type, the program applies a random color to it. To change it, click the Edit button

. This opens the Edit colors window.

There are four ways of modifying a color:

• Choose color from  Basic colors –  this color

will become your selected color.

• Drag the cross cursor   and/or click on

the lightness bar to move its cursor   to

define the color in the color space.

• Enter  the  RGB  values  in  the

Red/Green/Blue fields.

• Click the Color picker icon . With it, you

can choose any color from your screen – by

clicking a point on a screen, you change the

color  to  that  which  is  located  under  the

pointer.

Figure 23: Editing colors
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2.2.13 SHADING MODES OF THE REGION

There are three different types of the region shading mode. Click the mode icon  in the toolbox to

switch between them. The three modes are:

• Flat : program just puts the texture over the region without regard to its original shade.

• Shaded : program takes shades of an original image. The region color will be a

sum of background image shades and the specified color or fabric texture. In the

white  area,  the  texture  remains  the  same,  in  other  areas  it  becomes  darker,

depending on the brightness of  the original  image.  You can adapt the level  of

brightness in  the model  with the brightness  tool,  by clicking  and dragging  the

control points.

• Shiny  : program takes shades of the original image. At middle level 128, the

texture remains the same, but it becomes darker to the levels close to 255, and

lighter to the levels  close to 0. You can change the brightness’ middle level  by

changing the Mid-tone parameter. You can choose the Mid-tone parameter from

the image with a mouse:  Shift+left click on the pixel of the region sets the Mid-

tone parameter to match the brightness of the clicked pixel. You can also change it

manually by setting the parameter.

The Strength parameter regulates the strength of the lightness (darkness) of the

original model. If you find that the contrast is too strong, reduce the default value

of 50. If you set the Strength parameter to 0, you will get the same result as with

the Shaded mode .

Figure 24: Region without texture, and in Flat, Shaded and Shiny mode

The region shading works on both, textures or colors. textures and colors.
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2.2.14 TEXTURE ZOOM LEVEL

When you copy a texture into the region for the first time, the program chooses its magnifying factor

from the model physical size (dpi) and the texture size. But you can change the zoom level of each

region by yourself with one of two methods:

• By using up and down arrow keys on your keyboard.

• By using the numeric Scale entry field on the bottom right of the main ArahDrape window.

Figure 25: Same texture at different zoom levels.
 

The actual size of the texture (the repeat size in centimeters or inches) is displayed as a tool-tip in the

image browser. You can set the texture dpi or actual size in ArahPaint. A size is calculated from image

dpi and the number of pixels in the texture. If you save a fabric texture from ArahWeave, then the

correct texture size is set automatically.

2.2.15 ROTATION ANGLE

Textures can also be rotated. The default center of rotation is at the first border point of the region,

but can be moved to the desired place by double clicking with the left mouse button inside the

region. The current position of the center of rotation is marked by a small  circle.  You can set the

angle of rotation:

• By using the left and right arrow key on the keyboard.

• By entering a value in the Rotate field in the right bottom corner of the main ArahDrape window.

Figure 26: Rotating a texture by 45
degrees
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2.2.16 X:Y RATIO

Sometimes you can’t achieve a proper texture look only with the Scale setting. By setting the X:Y ratio

(the texture width/texture height ratio), you can increase or decrease zoom only in one, horizontal or

vertical direction. It is mostly useful to correct the texture alignment between two regions. 

Figure 27: Changing X:Y ratio; by decreasing the ratio,
the pattern width in selected region matches the one in neighboring region  

2.2.17 SETTING THE REGION VECTORS

Textures often look unnatural on the model, because the newly applied textures do not follow the

shape of the original model. You have to specify the geometric distortions in the fabric caused by

perspective view, creases or simply the 3D volume of the product. To accomplish this goal, select the

region, which you want to modify, and use the grid tool. You can get the Grid window, if you click on

the grid icon  or select menu Regions > Grid.... You can set the grid for one region at a time. There

are two different grid types: 

• Use Simple when you have an easy perspective mapping, like a carpet on the floor. You will have

a rectangle, which you should distort into a trapezoid, which matches the desired geometry of

the mapping. 

• Use Complex for anything more complicated.

2.2.17.1 SIMPLE

When you  open the Grid  tool,  the  Grid  type is  set  to  the  Simple mode.  The program  draws  a

rectangle with control points. You just need to drag the corner points to adequately position. The

program will redraw the texture. When you think that the vectors are in proper position, close the

Grid window.
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Figure 28: Before and after applying the Simple grid

 

2.2.17.2 COMPLEX

Usually the regions are not that simple, so the Complex grid is used on most regions.

Vectors of the complex  grid  are the guiding  lines  for the mapping of a texture to the area.  The

vertical and horizontal vectors should intersect, and their borders should be outside the regions. As

a minimum, you will need two vertical and two horizontal vectors. 

To create the complex grid, select a region and click the Grid tool Icon. In the Grid window, click the

Complex button. Then click the Horizontal vector button or the Vertical vector button. The mouse

cursor changes to ⇐ for horizontal or to ⇑ for the vertical vector drawing mode. To start drawing,

click on the place where you want to have the vector starting point. Then drag a mouse and click

again on the place, where the next point should be. Continue till you draw the last point and finish

drawing the vector by clicking on the right mouse button. To draw the next vector, click again on one

of the vector labels (Horizontal vector or Vertical vector). Vertical vectors should be drawn from top,

and  horizontal  from  left  to  right.  If  the  fabric  has  many  complicated  distortions,  you  can draw

intermediate vectors.  You should not mix up vertical and horizontal vectors, and do not forget to

intersect them. If you make a mistake, the program will not generate any mapping, until you correct

the vectors and make them valid.

On the left picture below, we are in the middle of drawing the vertical vector (note the cursor arrow),

and the picture on the left shows the finished state:  two vertical  vectors in  dark  red, and three

horizontal vectors in orange.
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Figure 29: Drawing vectors for the grid   

You can also click the Show grid button in the Grid window, to see a grid used in the mapping. You

also can increase the grid’s Density; this will make smaller rectangles in the mapping. In most cases,

default  grid  density  will  do just  fine.  ArahDrape view mode (Image,  Regions,  Regions and drape,

Drape) can be toggled during the creation of the grid.

Figure 30: Grid used for texture mapping
 

Once you finish setting the grid for one region, close the Grid window, and click the next region with

the left mouse button to select it, and open the Grid window again. 

2.2.17.3 MODIFYING THE GRID

• To insert a point into an existing vector do one of the following:

◦ Click on the vector with the middle mouse button.

◦ Click on the vector with the right mouse button, and choose Insert point from the pop-up

menu.
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Figure 31: Two ways of inserting a point to existing vector
 

• To move a point, click on it with the left mouse button and drag it to a new location.

• To delete a point do one of the following:

◦ Click on the point with the middle mouse button.

◦ Click on the point with the right mouse button, and choose Delete point from the pop-up

menu.

• To delete a vector, click on the point with the right mouse button, and choose Delete vector from

the pop-up menu.

• To move a vector, use Ctrl+drag and drop (move the mouse pointer to the vector point, press the

Ctrl key and hold down the left button on the mouse, drag the vector to the desired location by

moving the vector to this one, drop the vector by releasing the button).

• To duplicate (copy and paste) a vector, click on the point with the right mouse button, and choose

Duplicate vector from the pop-up menu. The program will  draw another identical vector, which

you can move it by CTRL + left mouse button drag to desired place. This is useful in cases, when

you need two similar vectors, but you want to avoid the drawing.

Figure 32: Duplicating a horizontal vector, and moving it to a new location

2.2.17.4 REVERSING VECTORS

The orientation of the texture depends on the position of vertical and horizontal vectors. Sometimes,

after you have already drawn vectors for a particular region, you notice that it would be better, if the

horizontal and vertical vectors would interchange their position. There is a function to do this: click

the Reverse button  in the Grid window. Vectors will exchange their function: vertical will

become horizontal and vice versa. You can also use this function to fix the display of text on a texture,

if it appears mirrored.
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Figure 33: Reversing vectors

2.2.17.5 STRETCH OPTION (DEPTH OF OBJECT; THIRD DIMENSION; PERSPECTIVE)
ArahDrape maps a texture as the region is  in one plane by default, and it doesn’t know anything

about the depth of the object (third dimension). Usually, the texture looks unnatural on an object

with obvious depth.  In  such cases  the  Stretch function allows  you to approximately  represent a

texture on an object in perspective. 

Figures from  34 shows the mapping on an object (a sofa seat). As you can see,  ArahDrape doesn’t

take the depth of an object into account. The dimension of the pattern on the seat is apparently

wrong.

Figure 34: Mapping on an object without regards to perspective
 

Before applying the Stretch function, we have to prepare a set of horizontal vectors and place them

on a much larger area than the region area itself. To do this, extend the vertical vectors much above

the region area, then add horizontal vectors (faster way is with the duplicate vector function than

with drawing them), and arrange them evenly on the vertical vectors (use Ctrl+mouse drag to move a

vector on a desired position). In the sample on Figure 35 we have placed the vectors in such a way,

that  the  distance  between  two  horizontal  vectors  is  four  grid  cells.  This  distance  is  not  really

important; it just helps to have more control.

Figure 35: Adding horizontal vectors
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Then enable the  Stretch function in the grid window. Nothing happens so far, but from now, the

number of grid cells between two vectors is fixed. In our case it is four, no matter what the distance

between vectors  will  be.  When you move a vector,  the area between it  and adjacent vectors is

stretched - there are still 4 grid squares between two vectors, but the size of squares is different (so

as mapped texture). In our case, the density of the vectors increases at the far end of the object.

Figure 36: Using Ctrl+mouse drag to move the vector

The cells are bigger at the front, so the texture appears in perspective.

Figure 37: After moving all horizontal vectors
 

Figure 38 shows the final result after closing the Grid window.

Figure 38: Perspective mapping
 

Please note: if you add a new vector, the grid will  be recalculated and you will loose previous stretch

setting – you will need to re-position the vectors.
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2.2.17.6 DELETING ALL VECTORS

If the grid vectors don’t intersect the opposite vectors, ArahDrape

can’t  map a  texture  to  the  grid.  In  a  really  complicated  vector

setting it  is  difficult to find a vector, which causes a problem.  In

such cases use a function in the Grid  window: Clear  > Incorrect

vectors. If you need to delete all vectors, click the All button in the

Clear section of the Grid window.

Figure 39: Clear vectors section
of the grid window

2.2.18 IMAGE OFFSET VIEW

Sometimes you will have a region very close to the border, therefore you will not be able to draw

grid  vectors freely  over the edge.  In these cases use  View  >  Image  offset.  You will  get an extra

border, which should give you enough working space around the image. If there is still not enough

space, go to Files > Preferences… and set the desired offset size in pixels.

Figure 40: Drawing vectors outside the image  

2.2.19 MOVING THE TEXTURE 
The start of fabric texture within a region is not independent from the other regions. On a normal

shirt, the fabric on the pocket needs to be aligned with the body. To match the starting offset of two

neighboring regions, click anywhere in the region with the left mouse button and drag the texture to

the desired position. The program will  interactively move the texture offset as you will  move the

mouse.

Figure 41: Moving a texture: click, drag, and release a texture  
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2.3 SAVING THE PROJECT FILE

To save changes to the current file, choose File > Save project.

To save a project with a different name and location:

1. Choose File > Save Project As.

2. Choose a location for the file, and type a filename.

3. Click Save.

The extension .drape will be added automatically.

2.4 FILE PREFERENCES

In  the  Preferences  window,  you  can  edit  the  colors,  which  are  used  for

drawing  ArahDrape objects  (Region,  Grid,  Horizontal  vectors,  Vertical

vectors),  and the image  offset (in  pixels),  which is  used when viewing an

image in the Image offset view. To open a dialog, choose File > Preferences.

To edit  a  color,  which is  used for a  particular  object, click  on the palette

button next to the colored label. This will open the Edit colors window. There

are  four  ways  to  edit  a  color  in  the  Edit  colors  window,  as  described  in

Chapter 2.2.12.

All values from the Preferences window are saved in the project file.

Figure 42: Editing file
preferences

2.5 REPLACING A MODEL IMAGE IN A PROJECT FILE

Sometimes you need to edit a model picture in other programs (photo editing software), which you

used in an  already finished project. If you don’t change the image pixel size, you can load it as a

model into a project file.  ArahDrape will preserve all properties of the original project file (regions,

vectors...) and will only replace the model image. If you want to keep a new image in the project, you

have to save it again.

This is useful when you used to add logo, text, or any image retouching operation after you have

made your drape project.

You can also use the PNG image for a model when you need maximum quality, and JPEG image,

when you want a small file size.

2.6 SAVING (EXPORTING) AN IMAGE OF THE PROJECT

If you want to send the picture by e-mail to the customer, or prepare pictures for publishing on the

web, you have to export it from ArahDrape.
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Choose File > Save image as, and choose a format from the drop-

down list. Then you can change the relative size of the exported

image; the default is at 100%, other possibilities are 50%, 33%,

25% and 20% of the original image size. Usually we reduce the

size  of  the  exported  image  to  get  nice  anti-aliased  borders

between  object  and  the  background.  If  you  like  the  default

filename,  which  consists  of  a  project  name  and  a  graphic  file

format extension, just click the OK button, otherwise change the

filename and confirm it with OK.

Figure 43: Saving an image

Then you can edit exported images in other programs.

Figure 44: Using exported images for a presentation
 

If you want to keep the transparency from the input image, you have to choose PNG or TIFF as a

format for saving the image.

2.6.1 APPLYING TEXTURES AND EXPORTING IMAGES IN BATCH

If you need to apply a lot of textures to the same model, ArahDrape supports batch processing.

Choose Textures > Browse texture and save image. Load a texture from the browser to replace the

current texture in the panel.  ArahDrape applies a texture to the object, and saves its image in the

default  directory.  The file  name of  the saved image  is  written  automatically  and consists  of  the

texture filename and the drape project filename. Then you load another texture, ArahDrape saves the

image, and so on. Instead of manual texture loading, you can use the auto-load function. Just press

the equal symbol (=), and ArahDrape will load texture after texture as they are ordered in the texture

browser. You can stop the process by clicking inside browse window.
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If you want to save the image in another format than the one currently chosen in the Save image as
window, you have to choose it, before starting the batch process.

2.7 MULTIPLYING (INCREASING THE NUMBER OF PIXELS) A PROJECT FILE

It is advisable to multiply the project file before exporting the image if:

• The input image (model) size in pixels is quite small.

• We want to reduce the effect of moiré in the exported image.

To multiply a project file, choose  Models > Multiply > X2 (or  X3, X4, X5). All elements of the

project, like a model, textures, regions, vectors will be scaled by the selected factor.

Figure 45: Multiplying by 4; note, that the size changed from 400x575 to 1600x2300 (by 4)

When  you  save  an  image  of  the  multiplied  project,

ArahDrape automatically chooses the scale factor for the

image.

Figure 46: Exporting multiplied project

Figure  47 displays two images of the same shirt. The one on the left was saved from the original

project file, while the one on the right was saved from the multiplied project. The final size in pixels

of both images is  the same, but you can notice that the texture of the multiplied image is  more

regular and has less moiré. The transition between the shirt and the background color is noticeably

smoother (anti-aliased) on the multiplied exported image.
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Figure 47: The shirt image on the left was saved from the original project file; the one on the right
was saved from the multiplied project. The texture on the right is more regular, and the shirt edges

are smoother.

2.8 HIDING OR CHANGING A BACKGROUND OF THE MODEL IMAGE

2.8.1 VIEW > MODEL

You can hide the background of the model image by using View > Model. All parts of the image which

were not selected as regions, are shown in white.

Figure 48: Disabling the Model option from the View menu enables you to hide the background of the
image

2.8.2 BACKGROUND REGION

A background region has its borders around the entire image – so it acts on the whole image minus

area, which is selected as “normal” regions. Normally you add it after you have drawn all regions of

the model. You could draw it manually as any other region, but there is a function Regions > New >
Background region, which adds it automatically. With the background region you get more options to
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modify the background of the image. You can change it to non-shaded color (it is similar to View >

Model), you can change the color of the background, but keep the shades or you can replace the

background with a texture.

Figure 49: Adding the background region and mapping a color or texture to it.

2.9 UNDO / REDO

Undo command in the  Edit menu  Ctrl+Z,   restores the  project to its previous state. To  Redo last

operation, choose Edit > Redo Ctrl+Y, .  The program supports 30 undo steps. You cannot undo the

loading of textures or models.

2.10 PREVENTING ACCIDENTAL MODIFICATION OF FILE

When you finish and save the project file after you have tweaked variable settings, you can prevent

the file from accidental modification, like movement of a region point, deleting of regions, changing

zoom and similar.

To activate it, click the lock icon  in the main toolbar. It changes to a closed lock . In this state,

only textures can be changed. If you need to alter the file, click the lock icon to open it.
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2.11 PRINTING FROM ARAHDRAPE

To  print  an  image  from  ArahDrape,  select  the  Print  picture
function from the File  menu. Note, that  ArahDrape always prints

an image in a current View mode and that the program scales the

image to fit it in the specified Print size area.

To control the size of printout and its position on the paper, enter

the print size (Print width and Print height), and position (distance

from top and left border of the paper), in the fields in the  Print
size area. To check the maximum printable area, press the  Full
page button. If  you insert an area out of range (too big for the

paper size), it will be trimmed to a particular printer size and you

will be warned with a beep.

The default print orientation is a portrait mode. You can change

the  print  orientation  by  checking  the  Landscape button.  This

option can be useful for printing objects that need to be displayed

horizontally.

If you create textures with ArahWeave, then use the Color matching

option when you save them. On printers supported  by Arahne, the

colors of the textures will be more accurate.

Figure 50: Printing a project
image from ArahDrape

When you enter the settings, check the Print
preview. It displays a picture exactly as it will

be placed on a paper (left and top offset). If

everything is in the proper place, close the

print preview, and click OK.

Figure 51: Print preview displays a picture as it will
appear on paper

2.11.1 PRINTER SETUP

If you want to print to a different printer or file, you

should select Printer setup in the Print picture dialog

to  change  printer  settings.  In  the  Printer  setup
dialog,  you  have  to choose  the  desired  printer  or

graphics file format, print mode and density (in dpi –

dots per inch). For higher quality printouts use 1440

dpi, but in most cases 720 dpi is sufficient.

Figure 52: Printer set-up
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2.11.2 TITLE OF THE IMAGE PRINTOUT (INFORMATION)
If you enable the Title option in the Print picture dialog, then you get a

title printed on the top of the printout. By default, the title is a project

filename,  but  you  can  set  a  different  title  by  entering  it  in  the

Information field (File > Information). Figure 53: Setting the title
for the printout

3  USING TRANSPARENT IMAGES EXPORTED FROM ARAHDRAPE ON A WEBSITE

ArahDrape enables you to create images of your products, which you can put on your website to give

your customers the option to configure the product to suit their needs and taste. Usually you divide

the image of the product into more images of the same size, each containing a part of the product

which will  be covered with a single fabric texture. When a customer makes a selection, the final

image  is  folded together from all  parts,  and a composite  product image  is  ready for  customer’s

evaluation.  ArahDrape is  able to generate hundreds of draped images ready for website use, but

ArahDrape does not do the website implementation. This needs to be done by the website designer.

Figure 54 displays a sofa divided into three images: the background, and two images of fabric parts,

which we will use in ArahDrape to create images for the web.

Figure 54: A sofa divided into three parts: a background, a main part, and pillows; a checked pattern
represents a transparent part of the image. When three images are laid over one another, you get

one composite image.

We have to create draped images from all the samples from the collection from both sofa images.
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Figure 55: Parts of the model saved with its own texture 

Once you have saved all  images, you can check them in some graphical program, which supports

layers and transparency.

Or you can write a very  simple  HTML file  to check how a web browser displays  images  as your

customers will see them on your web page. Here is an example of HTML code, which combines three

images (the background image and two layers) into a single image.

<HTML>
<HEAD><META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
charset=UTF-8"><TITLE>ArahDrape internet test</TITLE></HEAD>
<BODY>
<IMG style="position:absolute" src="sofa_arahne.png"/>
<IMG style="position:absolute" src="sofa_main.png"/>
<IMG style="position:absolute" src="sofa_pillow.png"/>
</BODY>
</HTML>

You have to save an HTML file in the same directory as images. Then open it in a web browser.
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Figure 56: A composite image displayed in the web browser  

4  VARIATIONS

ArahDrape enables you to create and save more variants of the same model in one file. Click the

Variations icon  in the main toolbox to open the Variations dialog.

Figure 57: The Variations dialog

Set the number of  variations In the lover  left corner of  the dialog.  Each row of  color or texture

thumbnails  represents  one  variation.  To  switch  the  view  between  variations,  click  one  of  the

thumbnails of particular variation. Load textures into other variations as you do for the first one. Type

of region among variations may vary; for instance, the region number 3 on Figure 57 is the Color type

in the first and third variation and the Texture type in the second variation.

The Variations dialog enables you to copy texture from one to another region, or switch textures

between two regions. The left mouse button copies selected region, while the middle mouse button

switches textures.
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5  ARAHDRAPE TUTORIAL

In this tutorial, we will present the whole procedure of making your own drape models from zero; in

a real-life presentation you will have the models already prepared, so you will just apply the different

fabric textures from your current fabric collection. 

5.1 LOADING A MODEL

Open ArahDrape by clicking on its icon on the desktop. You will need a picture of the model or the

product, with fabric areas in white or in single color. We want to keep the shades and the spirit of the

original photo, and just replace the fabric. If the model will already have the fabric with a pattern, we

will not be able to remove the pattern and insert a new one, while keeping the shades of the original

image. You can scan the picture, or make a photo with a digital camera, and transfer the image into

the computer. Then select Models > Browse…, and double click the thumbnail of the image.

 

The image will appear in the main ArahDrape window.
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5.2 CREATING REGIONS

First you have to draw limitation vectors around each region. Region is an area within the image,

where you want to overlay  a  fabric  texture,  or  a  hole  within  a fabric.  Choose Regions  >  New >

Vectors, or simply click on the Create new region icon . It changes into , which indicates that

you are in region drawing mode. Click to create the first point of the region. Position the pointer

where you want the first straight segment to end, and click. Continue clicking to set endpoints for

subsequent segments. To close the region border, position the pointer over the starting point, and

click, or right click to close the region from your current position to the starting point.

There are user friendly functions for editing regions:

• If you want to stop drawing the region, you can press the right mouse button at any time, and the

program will close the region from your current position to the starting point.

• If you make a mistake and want to delete just the last point which you have drawn, press [Esc] key

on the keyboard. It will work several times.

• If you want to add a point into an already finished region border, point a mouse cursor where you

want it, and click with the middle mouse button.

• To delete a point, click on it with the middle mouse button.

• By clicking on the left mouse button you can move a point – keep the mouse button pressed and

drag it to a new location.

• To delete the whole region, click on a region and press [Del] key on the keyboard, or use Regions >
Delete from the main menu.

 

The default color of the active region is blue, while the color of unselected regions is red. The colors

of lines can be changed in Files > Preferences....
On many occasions, the limits of one region will border another region. You will  need to draw the

points of your new region on the same point as the bordering regions, otherwise they will not join

correctly  and  some  pixels  will  “shine”  through  the  borders.  This  can  be  quite  a  dull  and  time
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consuming task. We will show you a trick, which will allow the program to automatically draw the

area border vectors along the existing area.

To draw another region, click the Create new region icon  again. Start drawing vectors around the

shirt pocket: look at the points 1, 2, 3, 4 on the picture below. Instead of clicking on many border

points along the pocket from point 4 onwards, we will make a shortcut directly to point 5.

 

Now press the spacebar, and the program will  automatically draw new vectors along the common

vectors between the last two points.
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Obviously, there must be a connected path of vectors of other areas from one point to the other, or

the program will not know what to do. Program will always choose the shortest connected path—it is

a genuine shortcut! You must draw region borders for all areas—including the holes in regions, like

the buttons. Once you have drawn all the borders, you will be ready to load the texture, which you

want to drape over the area.

5.3 TEXTURES

Texture can be any picture in a supported graphical format (PNG, TIFF, GIF, JPEG). It will probably be

in repeat, but you may also use texture pictures, which do not repeat themselves.  If you scan or

photograph a fabric, you will probably spend some time adjusting its repeat. The easiest way to make

a fabric texture is to save a fabric simulation from  ArahWeave.  This way you can be sure that the

image will  have perfect repetition. The following screen shot shows the window for saving fabric

textures in ArahWeave. You call this function in ArahWeave if you click on Files > Save fabric texture...
The options are pretty straight forward:

• You can set image formats (JPG, PNG, TIFF).

• dpi - dots per inch; probably 100 to 150 dpi will suffice for most cases.

• Filename is set automatically  based on the current fabric name plus the suffix from the chosen

image format.

• The program displays the actual texture size in pixels above the filename, so you have the feel for

the size of your texture. If your fabric repeat is small, and the pixel size is 3000x3000, then your dpi

is probably too high. If your image repeat is very big, you can also lower the dpi to get a reasonably

sized fabric texture.

 

We can now return to ArahDrape. If you wish, you can keep ArahWeave open and create textures on

the fly, as you need them.  To load textures into  ArahDrape,  use  Textures  >  Load  texture....  The

Browse window is shown in the following picture. It has some options like Repeat, Size, Date... their

meaning is quite obvious, do not be afraid to try them out. You can also rename the file, if you click

on filename, or delete it, if you select it and hit [Del] button. If you want to get a better view of the

texture, click on it with the right mouse button, and it will open in full screen mode. You can use +

and - on the keyboard to zoom in, or [PgUp] or [PgDown] to load the next or previous image. Click the

right mouse button again to close the full screen image preview.
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Double click the desired texture to load it into ArahDrape. It will be displayed on the icon bar on the

right below the icons. If you want to unload the texture from the program, you can either click on it

and load a different texture in its place, or press [Del] on the keyboard to get rid of it. This will not

delete the texture file; it will just remove it from ArahDrape.

5.4 VIEW MODES

We are at the point where we need to specify the textures to our areas, so you must change the View
mode from  Regions to  Regions and Drape in the top-level menu. Each region can be any of three

types: 

• Color 

• Texture 

• Hole 

Initially, all the regions will be of the type color, so the shirt will look like a patchwork.
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Now we want to change them from a color to a texture mode. It is a very easy thing to do, and

experienced ArahWeave users will know what to do: Click on the fabric texture icon on the right with

the left mouse button, then point to the desired region and paste it  there with the right mouse

button. You can also copy region properties from one region to another – use the left mouse button

to select a region, and right to copy. Region type, texture and zoom level will be copied, while the

angle of rotation will remain intact.

 

Once you paste the texture to the region with the right mouse button, you need to set its zoom level.

You can do it in a purely visual way by using up and down arrow keys on your keyboard. Alternatively,

you can use the numeric Scale entry field on the bottom right of the main ArahDrape window.
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5.5 SETTING THE REGION TYPE

There are three different types of the region shading mode: Flat, Shaded and Shiny. To modify the

mode of the region, first select that region, and then switch between the modes by clicking the Shade

mode icon  in the toolbox.

• Flat : program just puts the texture over the region without regard to its original shade.

• Shaded : program takes shades from the original image. The region color will

be a sum of background image shades and the specified color or fabric texture. In

the white area, the texture remains the same, in other areas it becomes darker,

depending on the brightness of  the original  image.  You can adapt the level  of

brightness in the model with the brightness tool.

• Shiny  : program takes shades from the original  image.  At middle level  128,

texture remains the same, but it becomes darker to the levels close to 255, and

lighter to the levels close to 0. You can change the brightness’ middle level with

changing the Mid-tone parameter. You can choose the Mid-tone parameter from

the image with mouse: left click + Shift in the pixel of the region sets the Mid-tone

parameter to match the brightness of the clicked pixel.  You can also change it

manually by setting the parameter.

The Strength parameter regulates the strength of the lightness (darkness) of the

original model. If you find that the contrast is too strong, reduce the default value

of 50. If you also set the Strength parameter, you will get the same result as with

the Shaded mode .

The region shading works for textures and colors.

If  you are draping based on a photo, you will  prefer to have it shaded, while flat might be more

appropriate for quick fashion sketches.

The region in shaded mode has an extra gray square on the bottom right angle of the main window.

You can see it in the picture below. Use two control points to adjust the lightness and darkness of

your shades.  The upper right point controls  the light shades, while  the bottom left controls  dark

shades. Try moving the control points with the mouse—effects will be immediate.
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5.6 COPYING TEXTURES FROM REGION TO REGION

As you copy the texture from one region to another with a right mouse button click, you also copy the

zoom level and a lightness of that region. You should also set the region type to hole for buttons and

labels.

 

If you want to get a more realistic view of the final image without the region borders, select View >
Drape.
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5.7 SETTING THE GRID 
We have  all  the  nice  shades,  but  the  image  still  looks  somewhat  flat.  Why?  It  looks  unnatural,

because the newly applied textures do not follow the shape of the original model.

We must specify the geometric distortions in the fabric caused by perspective view, creases or simply

the 3D volume of the product. To accomplish this ambitious goal, we will use the grid tool. You can

get the Grid window, if you click on the grid icon  or select menu Regions > Grid... Do not forget to

click on the desired region first—you can set the grid for only one region at the time. There are two

different grid types: 

• Use Simple when you have an easy perspective mapping, like a carpet on the floor. You will have

a rectangle, which you should distort into a trapezoid which matches the desired geometry of the

mapping. 

• And use Complex for anything more complicated.

Our case requires the use of a complex grid, so you should select it. Then click on Vertical vector and

draw it in the main window besides the selected region. Draw it in the same way as you did the

region just that it does not end with a starting point. Finish drawing the vector by clicking on the right

mouse button. Vectors will be the guiding lines for the mapping of your fabric texture to the area.

The vertical and horizontal vectors should intersect, and their borders should be outside the regions.

As a minimum, you will  need two vertical  and two horizontal  vectors.  Vertical  vectors should be

drawn from the top, and horizontal from left to right. If the fabric has many complicated distortions,

you can draw intermediate vectors. Do not mix up vertical and horizontal vectors, and do not forget

to intersect them.  If  you make a mistake, the program will  not generate any mapping, until  you

correct the vectors and make them valid. In the picture, you can see two vertical vectors in green,

and two horizontal vectors in red.
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Once you finish setting the grid for one region, close the Grid window, and click the next region with

the left mouse button to select it, and open the Grid window again. You can also click the Show grid
button in the Grid window, to see which grid will be used in the mapping.

 

You also can increase the grid's  Density; this will make smaller rectangles in the mapping. In most

cases, default grid density will do just fine. Adding, deleting, and moving grid vector points works the

same as on region vectors: to add a point into an existing vector, just press the middle mouse button

on the vector; to delete a point press the middle mouse button at the point. If you want to delete the

whole vector, point the mouse cursor at one of the points of that vector, press a right button, and

choose Delete vector. If you need to move the whole vector, you can do it by CTRL+ mouse button

drag. In some cases you would need two identical vectors, but it is difficult to draw two exactly the

same. So to do this point the mouse cursor at one of the points of that vector, press a right button,
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and choose Duplicate vector. The program will draw another identical vector, which you can move it

by CTRL + left mouse button drag to desired place.

Sometimes you will have a region very close to the border, therefore you will not be able to draw

grid  vectors freely  over the edge.  In these cases use  View  >  Image  offset.  You will  get an extra

border, which should give you enough working space around the image. If there is still not enough

space, go to Files > Preferences… and set the desired size in pixels.

 

The start of fabric texture within a region is not independent from the other regions. On a normal

shirt, the fabric on the pocket needs to be aligned with the body. To match the starting offset of two

neighboring regions, click anywhere on the region with the left mouse button and drag the texture to

the desired position. Program will interactively move the texture offset as you will move the mouse.

5.8 SAVING A PROJECT

You should not forget to save your work at the end, use Files > Save project...; type the filename in

the and in the file selection box. The extension .drape will be added automatically.

As you have seen, making a good drape model requires some work, but when finished, we can use it

infinitely  with  different  textures.  You  can  load  other  fabric  textures  by  clicking  on  Textures  >
Browse...
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If  your drape model  contains many regions,  like  on the shirt  from our example,  you will  quickly

become tired of clicking on regions with the right mouse button to apply a different texture. One

would like to copy the new fabric texture to all regions, which currently have the same texture. To

achieve this, click on the group icon  in the toolbar. It will change itself to , so that you know

that ArahDrape is in “group” mode. From now on, you can use a single click (right mouse button) to

copy texture to all  regions with the same texture. You can then disable the group to change the

region type individually, if you wish. For example, you can make the shirt collar and wristband white,

if you change their region type from texture  to hole .

Textures can also be rotated. The default center of rotation is at the first border point of the region,

but can be moved to the desired place by double clicking the left mouse button. The current position

of the center of rotation is marked by a small circle. The shirt on the lower picture has it in the middle

of the right pocket. You can set the angle of rotation by pressing the left and right arrow keys on the

keyboard, or by entering a value in the Rotate field in the right bottom corner of the main ArahDrape

window.
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5.9 SAVING THE FINAL PICTURE

As always, we are doing this to impress our potential customers, or to help them choose between the

different variations of our products. So we need to find a good way of showing our draped images to

them. One way is to invite them in front of the computer, and insert the textures from your collection

as you talk  to them.  This  will  probably  be the most  effective  way,  since it  will  also  involve  the

customer. If such a presentation is not possible, you can also print the drape simulation from Files >
Print picture... If  you want to send the picture by email  to the customer, or prepare pictures for

publishing on the web like in our drape gallery, you can save just the drape image using Files > Save
image as...
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6  LIST OF ACCELERATOR KEYS IN ARAHDRAPE:

(Note that the main window has to be active

for the accelerators to work)

1  zoom level 100%

2  zoom level 200%

...

9  zoom level 900%

0  zoom level 1000%

Ctrl+mouse wheel – zoom in, zoom out

Zoom in: +

Zoom out: -

VIEW MODE

i  image

r  regions

e  regions and drape

d  drape

o  toggles the image border offset (on/off)

Shift+left  click  into  region  sets  the  Mid-tone

value for that region.

REGION TYPE

c  color

t  texture

h  hole

s  toggle shading

b  browse textures

CTRL+b  browse images (models)

CTRL+q  quit program

DEL (in main window) deletes selected region

DEL  (in  textures  window)  deletes  selected

texture

Undo: CTRL + z

Redo: CTRL + r

Arrow keys UP and DOWN will  zoom texture in

the  selected region.

Arrow  keys  LEFT  and  RIGHT  will  rotate  the

texture in the selected region

=  Browse textures window (first texture icon should be selected, and the browse textures window

should be active)

7  LIMITS

Maximum model image size: 32000x32000 pixels.

Maximum texture image size: 32000x32000 pixels.

Maximum image offset: 5000 pixels.

Maximum number of regions: 500.

Maximum number of variations: 30.

Maximum number of points in region: 1000.

Maximum number of points in region vector: 1000.

Maximum number of textures in the sidebar: 200.

Maximum number of undo steps: 30

Supported image formats in saving draped images:

• JPEG

• PNG (with transparency, if model was transparent).

• WebP (WebP yields files that are smaller for the same quality, or of higher quality for the

same size.)

• TIFF (with transparency, if model was transparent).

Supported image formats in loading (for models or textures):

• JPEG
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• PNG

• WebP

• TIFF

• BMP

• GIF

• PCX

• many other weaving and proprietary CAD formats.
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